Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
'09 E350 4-matic sport, '83 240D 4-speed (sold), '77/'78 450SLC (junked), '81 500SLC (junked)
Joined
·
845 Posts
Discussion Starter · #1 ·
I bought myself a chinese Klann clone and went ahead and put my rear Vogtlands on today. The process was relatively painless except that I realized my 19mm socket was missing at a critical moment--hopped in the SLC, picked one up, and the whole thing was done in a couple hours.

The only sketchy part is releasing the new spring into its seat. On the first spring I was in the process of removing the compressor plates when the spring adjusted itself ever so slightly (but loudly) and bit my finger a bit. This made me nervous as hell when doing the second spring. Then after you're done and you are jacking the car up and down, you hear pops and cracks as they continue to seat themselves.

I plan on tackling the front suspension on Monday (UCAs, LBJs, drag link, springs and pads, the bushing on whatever that arm is called, and the guide rod mounts). Next are the rear subframe, differential, tranny, and engine mounts.
 

·
Registered
'09 E350 4-matic sport, '83 240D 4-speed (sold), '77/'78 450SLC (junked), '81 500SLC (junked)
Joined
·
845 Posts
Discussion Starter · #2 ·
At some point last night, I suddenly woke up and to the strong feeling that I'd left those white caps off the shock mount access holes. Sure enough, they're sitting right up there on the hat shelf.

:mad:

Messing with that seat has to be my least favorite Benz-related activity.
 

·
Registered
'09 E350 4-matic sport, '83 240D 4-speed (sold), '77/'78 450SLC (junked), '81 500SLC (junked)
Joined
·
845 Posts
Discussion Starter · #3 ·
Well, I still didn't put those covers back on, but I got my tax rebate yesterday and even though it was smaller than I expected, went ahead and ordered the transmission and differential mounts from the dealer. Not too pricey (~$170 total).

I noticed I had a bit of a rear camber problem after putting on the Vogtlands so I installed my new subframe mounts today. I couldn't get the edges in all the way but I guess they'll work their way in with time. I'll check the big bolt every now and then for the next couple weeks. Does anyone know the torque spec. for those bolts?

The mounts came with new carrier bushings or whatever those are called but I didn't bother putting them in yet.

The new mounts raised the subframe about 1/2" at least and the rear camber is almost gone. The diff. mount should take care of it the rest of the way.
 

·
Registered
'09 E350 4-matic sport, '83 240D 4-speed (sold), '77/'78 450SLC (junked), '81 500SLC (junked)
Joined
·
845 Posts
Discussion Starter · #4 ·
Actually, after driving around a bit, the rear camber is worse than I thought. I'm not sure if the new differential mount will take care of it or not. Does anyone else have a rear camber problem after putting on their Vogtlands?
 

·
Registered
money pits of various forms
Joined
·
5,885 Posts
Yes. Dont worry about it if its not to bad. Pics?
 
1 - 5 of 5 Posts
Top