Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
1979 240D
Joined
·
69 Posts
Discussion Starter #1
For the past couple of months, the speedometer in my 240D has been reading slow, and on the last super cold day, it stopped working completely. The rest of the gauges and the clock work fine.

Two questions - can I replace just the speedo, and will one from a 300D or other W123 car work, or do I need one specifically for the 240D?
 

·
Registered
see signature
Joined
·
282 Posts
It may just be the cold.. My speedo/odo wasn't working the other day for the first time when it was very cold outside. This went on for quite some time and I figured I'd have replace the cable or gear, but then after the car warmed up quite a bit, it suddenly was working just like normal.
 

·
Registered
1983 240D Standard
Joined
·
24 Posts
Looks like there were three possible speedometer cables for the 1979 240D.

1310mm: 4spd Standard, chassis up to 219674
1420mm: 4spd Standard, Chassis 219694 on up
1390mm: Automatic

As far as borrowing from a 300D, I haven't done it but if the dash and transmission hookups on the donor car are the same as your car, it 'should' work.

Or you could skip the headache and order new for about $60.
 

·
Registered
!984 RHD 123 240D single owner
Joined
·
12 Posts
Spedometer 123 240D in India

It may just be the cold.. My speedo/odo wasn't working the other day for the first time when it was very cold outside. This went on for quite some time and I figured I'd have replace the cable or gear, but then after the car warmed up quite a bit, it suddenly was working just like normal.
I live in India where cold is not an issue. My speedometer used to be sluggish at the start but work fine after some time, but of late it has gone dead. Should I replace the cable? and is difficult to replace the cable?
'Hanes' manual does not show how to replace the cable.
Thanks
Ramanna
Bangalore
 
1 - 7 of 7 Posts
Top