Mercedes-Benz Forum banner

1 - 6 of 6 Posts

Registered
Joined
3 Posts
Discussion Starter #1
Hi there
I have 2004 c240 2.4 v6 wagon which needed service B then I changed oil ,brake fluid and spark plugs(since the old ones were old and bad)When I switched on the car the engine was misfiring and shaking in a way that it wanted to jump out of the car馃憖when I took off the newly put spark plug to check them they were already black like they were burning
Any ideas of what could be wrong or what should be changed????
NOTE..I also changed the MAS and cleaned up the throttle body
Thank you fo your help
 

Registered
2002 Mercedes ML320, Mercedes 190E 2.3L (sold), 2001 Mercedes c320(gone)
Joined
1,391 Posts
Hi, what type of spark plugs did you put in the car? You should also ensure proper sealing at the MAF sensor elbow to ensure there's no excessive unmetered air into the engine.

Ensure also the MAF is good to go. Confirm fitment, authenticity and compatibility

Sent from my Pace 2 Lite using Tapatalk
 

Registered
Joined
3 Posts
Discussion Starter #3
Thanks for the info I'll look into that.
I used the Bosch spark plugs same from the dealer and as for MAF the one that i got didn't have rubber seals so i used old rubber seals
 

Registered
2002 Mercedes ML320, Mercedes 190E 2.3L (sold), 2001 Mercedes c320(gone)
Joined
1,391 Posts
Thanks for the info I'll look into that.
I used the Bosch spark plugs same from the dealer and as for MAF the one that i got didn't have rubber seals so i used old rubber seals
Ok great, let's know what you find, if you could get it diagnosed, any cheap scanner is good for something like this. Trouble it until the light comes so you get it on any obd2 scanner.

Sent from my Pace 2 Lite using Tapatalk
 

Registered
Joined
3 Posts
Discussion Starter #5
Hi there
The engine vibration went better after I realized I had swapped the coil plugs and another work I did was to change my crankshaft position sensor, now the car is super doper 馃憣
1 more thing I'd like to know is how to reset service B???
 

Registered
2002 Mercedes ML320, Mercedes 190E 2.3L (sold), 2001 Mercedes c320(gone)
Joined
1,391 Posts
O great news, nice. Good thing you figured it out. I think you may want to buy a scanner for the car also.

Service B, this guy may give you a hint:


If you had a scanner like the MD802 maxidiag elite by autel or even better you could afford SDS, you'll be doing the reset fairly easily.

The MD802 is Handy and very helpful for everyday use.

Sent from my Pace 2 Lite using Tapatalk
 
1 - 6 of 6 Posts
Top