Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
2005 C240 silver, 2008 R320CDI Cubanite
Joined
·
390 Posts
Discussion Starter #1
Hello
I installed the aftermarket DrawTite trailer hitch on my 2008 R320CDI without a problem. Easier than I thought. There were already cutouts on the plastic pan as well as nuts in the spare tire wheel well. I only had to remove the two tail pipe tips to access the bumper bolt and cutout a 1 1/5 inch by 8 inch part of the fascia.

However, while cleaning out the tire well I came across a 3 wire connector and what also seemed like an antenna or fiber optic cable in the bottom
The picture attached is from the connector. The spare tire must have been sitting on the connector and wire and it started sparking when I tried to clean it. I cut it off and sealed the ends.

Anyone know what this connector is for? Trailer hitch wiring?
 

Attachments

·
Registered
2005 C240 silver, 2008 R320CDI Cubanite
Joined
·
390 Posts
Discussion Starter #2
It ended up shorting out and blowing fuse #23 Radio. SO I gather it is audio related. Perhaps build in phone or TV.
 

·
W166, W251 Moderator
1987 560SL - Signal Red, 2014 ML350 - Diamond White, 2019 Ford Explorer - Magnetic (company car)
Joined
·
1,251 Posts
It ended up shorting out and blowing fuse #23 Radio. SO I gather it is audio related. Perhaps build in phone or TV.
Sorry, I have been busy, I'll check ours tonight, but could it be for the SAT unit?
 

·
Registered
2005 C240 silver, 2008 R320CDI Cubanite
Joined
·
390 Posts
Discussion Starter #4
I have sat,dvd res,navigation, Harman kardon cd changer and bluetooth phone. Only the front control display worked but nothing recognized. The only missing opt are tv, sos telaid and nonbluetooth phone integration. All working now again just curious what it was. I had water in the well. That must have caused the rust and corroded wire. Perhaps from a hatch rubber seal not installed properly after the latch mech was replaced in winter.
 

·
W166, W251 Moderator
1987 560SL - Signal Red, 2014 ML350 - Diamond White, 2019 Ford Explorer - Magnetic (company car)
Joined
·
1,251 Posts
Sorry I have not have time to check, will do tonight.
 

·
W166, W251 Moderator
1987 560SL - Signal Red, 2014 ML350 - Diamond White, 2019 Ford Explorer - Magnetic (company car)
Joined
·
1,251 Posts
I have the same wire/plugs free as you have, but mine was covered by a foam piece so that it cannot be squished by the spare tire.
I still have to figure out what it is for.
 
1 - 6 of 6 Posts
Top