Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
84 300D Turbo
Joined
·
56 Posts
Discussion Starter #1
I have a 83 300TD with 63,000 miles. We all know that sound ... the irritating sound of a bad wiper blade stuttering when you turn the wipers on. Well I have replaced the wiper blades 3 times in 2 months and that sound always comes back. The last time I ponied up extra for the teflon treated blades. Could it be the wiper arms? or is there slack in the wiper transmission assembly (would not think so with only 63,000 miles).

Any ideas? Thanks.
 

·
Registered
1991 300 SE
Joined
·
18,534 Posts
Could be something as simple as the correct blade application – I use the appropriate Bosch blade w/o any problem.
 

·
Registered
1959 220S cabriolet, 1983 240D original owner, 1999 E300 turbo diesel, 1988 560SL, 2003 SLK320
Joined
·
3,513 Posts
I've tried several brands of aftermarket blades on my 123 too and they are not nearly as good as the dealersupplied Bosch blades. It's also possible that your windshield needs a good treatment with Bon Ami to get it clean.

Len
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
I've tried waxing and it works. Right now I have Bosch blades, but since I purchased the wipers with the arms I kept my original wiper arms (with the Benz logo).
 

·
Registered
1983 300 D turbo
Joined
·
303 Posts
How long have you had this car? The past owner may have used Rain-X. The stuff works GREAT, but after a while, it does make your wipers make that ugly noise and kind of skips, unless it is a heavy rain. I still use it though, cuz at 55 mph, with no street lights on (no glare that way) my windows look dry. Pretty Cool.
 

·
Registered
84 300D Turbo
Joined
·
56 Posts
Discussion Starter #7
Thanks for all the inputs. Told my local parts store that my wiper blade problem still occurred even though the wipers blades are new. Guy behind the counter came out and looked at the wiper ARMS and said they were holding the wiper blades at the wrong angle. Suggested that I bend the arms a little to change the angle.

And it's worked for the past month .... no more wiper sounds even when the windshield is dry.
 
1 - 7 of 7 Posts
Top