Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
2000 ML320 / 1988 300SE / 1985 380SE / 1969 280SE
Joined
·
180 Posts
Discussion Starter #1
As soon as the engine is turned on, there is noise coming from the underneath of the car and it sounds like hitting something.

I was suspecting loose exhaust pipes but there wasn't any movement along the pipes or near the muffler.

The transmission mount was recently replaced.

Anyway, I am taking it to my mechanic for inspection tomorrow and interested in what he will find.

Has anyone experienced this kind of problem?
 

·
Registered
01 e320 4matic wagon
Joined
·
192 Posts
I know I have this problem sometime when hwy cruising and I believe it to be the heat shield/alum blanket that is flapping around. Might be worth to check that out while you're under there as well...just a thought
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,631 Posts
Hard to go on with that limited description, but if it's a lighter sound, like a rattling, that is likely the cats. Common issue. Hopefully they have some affordable aftermarket units over there.
 

·
Registered
2000 ML320 / 1988 300SE / 1985 380SE / 1969 280SE
Joined
·
180 Posts
Discussion Starter #4
Bingo. It was the cats.

There was tapping sound (or rattling). I first suspected the heat shield with loose bolts.
The mileage on my car is 188,000km.
I asked my mechanic how the cats can fail even before 200,000km and he said it could happen even before 100,000km.
If this is a common issue, does my cats failure sound reasonable at this mileage?
My 380se(1985 model) hasn't not shown this issue yet even after 200,000km.
Thanks for your input
Hard to go on with that limited description, but if it's a lighter sound, like a rattling, that is likely the cats. Common issue. Hopefully they have some affordable aftermarket units over there.
 

·
Registered
2000 ML320 / 1988 300SE / 1985 380SE / 1969 280SE
Joined
·
180 Posts
Discussion Starter #5
I paid AUD400 including labour

For aftermarket cats. USD400(=AUD400).
 
1 - 6 of 6 Posts
Top