Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2008, W204 200 CDI
Joined
·
1 Posts
Discussion Starter #1 (Edited)
Smoke through oil cap CDI 200 [OM646.811]

Dear members,MB experts,

I am fresh owner of W204 common rail CDI 200 with very low mileage (125.000km) well-mainteaned at local MB dealer. I was enjoying this MB until I opened oil cap on warm running engine. I become scared observing white smoke together with pulsing blowing.Let me describe symptoms.
Oil cap is dancing as teakettle at idle rpm and calming down at 1800 rpm.(but smoke is still present, visible at picture)



Car accelerates very well, maximal speed is easily reached, consumption is normal, cold start without problems, no abnormal clapping noise, engine does not eat oil!!!....so I can not believe that engine is blowby and it has significiant wear having weak pistons rings or damaged pistons allowing exhaust gas penetrate from combustion chamber into crankcase or camshaft cover. I got hint about burned injector sealing or malfunctioning PCV component. Can anybody help me with advice where to start to investigate this engine issue or if this issue exists itself at all. Is this smoke some vaporised oil or it is might exhaust gas (it smells like that)?

Thx so much for any advice:surrender:
 

·
Registered
2010 C200 CGI /W203/SLK230/W202/230E/280SE
Joined
·
3,301 Posts
Removing the oil cap (running) on any modern engine is going to make a mess and release some pressure (I wouldn't even think about it) - are you losing any coolant? - is the oil clear and not milky?

Could all be normal - pressures in a diesel would be higher than a petrol engine.

A compression test would tell you a lot.

Oberoi
 

·
Registered
Joined
·
1 Posts
Hi, I understand it is a very old thread. I have exactly the same symptoms as Andy220 described. I don't know how other w204s (c220 CDIs) are like ? is this level of blow-by normal /acceptable ? any expert advice will be highly appreciated,..please.
 

·
Registered
Joined
·
2 Posts
Smoke through oil cap CDI 200 [OM646.811]

Dear members,MB experts,

I am fresh owner of W204 common rail CDI 200 with very low mileage (125.000km) well-mainteaned at local MB dealer. I was enjoying this MB until I opened oil cap on warm running engine. I become scared observing white smoke together with pulsing blowing.Let me describe symptoms.
Oil cap is dancing as teakettle at idle rpm and calming down at 1800 rpm.(but smoke is still present, visible at picture)



Car accelerates very well, maximal speed is easily reached, consumption is normal, cold start without problems, no abnormal clapping noise, engine does not eat oil!!!....so I can not believe that engine is blowby and it has significiant wear having weak pistons rings or damaged pistons allowing exhaust gas penetrate from combustion chamber into crankcase or camshaft cover. I got hint about burned injector sealing or malfunctioning PCV component. Can anybody help me with advice where to start to investigate this engine issue or if this issue exists itself at all. Is this smoke some vaporised oil or it is might exhaust gas (it smells like that)?

Thx so much for any advice:surrender:
And now its normal or no?
 
1 - 5 of 5 Posts
Top