Mercedes-Benz Forum banner

361 - 380 of 410 Posts

·
Outstanding Contributor , SDS Guru
1998 MB E300TD, 1997 MB E36 AMG, 2001 MB E55 AMG
Joined
·
3,671 Posts
Aaaaw, who cares, let em rust away until they fall out facing the driver, so when Davey decides to be rude and honk at someone, he goes deaf?

That would be extra funny.
 

·
W220 Moderator
Joined
·
6,365 Posts
Discussion Starter #362
Cheers Sonny,

LOL, they will get a touch of Spray Grease for now, at the moment I'm concentrating on all the Mechanical and Electronic works, (Phase 1), then I will be driving the Car for the rest of this year, (Corona or not) ;)

Body and Paint (Phase 2) starts Winter 2020, if we are all still here 🤣
It's not like you can see 'em when the Grille is screwed back on, otherwise I too would have to do them :D

I cannot get an Annual MOT Test on it at the moment, due to all this stupidity, (the way UK are dealing with it, not the COVID itself), and UK are not making any exemptions for Private Car tests, thankfully I have Trade Plates valid until end of December 2020, so every time I use the Car I will be "Road Testing" it :)

Chow for now,
 

·
Registered
2000 S430, 2003 S430, 2000 S500, 2003 S600 TT, and 2005 E320 CDI
Joined
·
4,637 Posts
You're continuing to make that progress, Dave. You're gettin' there.

Some of our states over here are moving toward a lockdown as well. Gives me time to finish that Honda head gasket job that I've been meaning to do for a while. Also gives me time to work on the S600, so that's kind of a bonus.
 

·
W220 Moderator
Joined
·
6,365 Posts
Discussion Starter #364
Another update, another Milestone, another Epic piece of the puzzle completed ......................

I've just run the car up to Temperature, Cooling system bled out perfectly, all good so far, an interesting thing happened once it had been running for a while, the EML and the Coolant Light has come on, despite the Coolant Level being perfectly fine. Coolant Light was working fine when the V6 was in the Car, and the V8 had no Engine light or Codes prior to pulling it from the donor S Class ;)

I'm not that bothered at this stage, I suspect that they have both come on to tell me there is a fault stored in ME, Cooling System related, and if I'm correct in that hypothesis, (that's the posh word for guess), then it will be a Cooling Fan Circuit Malfunction Code because the Fan is yet to be connected up ;)

Despite no working Cooling Fan. and having it running for about 40 minutes, the Temperature never went any higher than 90 degrees C, this is a trait of having a brand new Radiator as opposed to a 100k miler, they are always super efficient straight outta the box ;) ....



Top hose was a real struggle / work of art from various V6 SLK and V8 S Class pieces to get it nice, you'll notice a P clip around it temporarily, just to stop it rubbing on the Fan Shroud edge, I will be making a small Bracket to lift it on the P Clip by 2 - 3mm soon there is also a handful more P Clips to be fitted here and there, wonderful things are P Clips :p ....









Auto Trans Cooler Hoses were a breeze, one was the Stock V6 SLK, and the other I just swapped a 90 degree end coupling for a straight one, the left side one looks close to A/C Pump / Belt in the pic, but IRL it's nowhere near it lol ....





Here's the final lower Radiator Mount Saddle pics, AC Condenser Pipe Bracket with new Cotton Reel Mount, lower Coolant Hoses etc etc ....









See if I can make a dent in Wiring the Cooling Fan for the rest of today, and then tomorrow I'll get car on SDS :D :D :D

More soon ................
 

·
W220 Moderator
Joined
·
6,365 Posts
Discussion Starter #366
Just a quickie re the Cooling Fan Wiring .............

Thanks @tusabes for confirming my guess, yeah, it runs too well for those 2 warning lights to mean anything else, I'll find out in a while when the SDS is out :)

I had a temporary "Brain Fart" yesterday and couldn't find the Wiring Colours in WIS to integrate the W220 Fan Wiring loom into the R170's Fan Loom, and the PWM Signal and Circuit 15 +ve Wires are different Colours on the 2 looms, but big thanks to @Deplore for helping out with the Colours for the new Wiring at short notice :)

I've posted the 2 diagrams below just in case anyone else is mental enough to do all this, and actually does get this far with an R170 RHD "Factory Build Quality" V8 Conversion :D :D :D .....................

W220 Wire Colours are :-

Yellow / Blue = PWM Signal Line

Black / Violet = Ckt 15 +ve

:D:D:D:D:D

Also worthy of note, which I had already worked out, the SLK 320 R170 has a 450W Fan with a 50 Amp Mega Fuse in it's Pre Fuse Box, for it's main Power Cable, the W220 uses 600W Fan and a 60A Mega Fuse, I will have to upgrade that today at the same time ;)





So I'm off to complete the Fan Wiring Loom and then a mass Workshop tidy up.

After that I'll stick the Auto Trans Custom Coded TCU in, and then fire up the SDS, gotta change the Version Coding in the ME2.8 to 600W Temic Suction Fan, then plug the Fan in and run it through it paces in the percentage tests :)

After that I'll run the Engine up to temperature again and study its Data to make certain all is "hunky dory" so far :)

Back Laters .........................
 

·
W220 Moderator
Joined
·
6,365 Posts
Discussion Starter #367 (Edited)
The Actual Fan I'm using is a 600W Temic CLK / C Class item with built in Fan Controller, (it was the slimmest one I could find), of course I didn't get the Wiring or Plug with it.

The Plug and Wiring is the same as the W220 S500 , so I stripped the Wiring and Plug out of the Donor Cars Loom, and have now integrated it into the SLK Loom that job is now finished ✅

Looking at this first picture highlights just how much serious cleaning I need to do in the Engine Bay, what you are seeing here is a whole load of dirt, dust etc etc stuck to the Waxoyl that the Cars PO sprayed liberally absolutely everywhere ....





So now that the Wiring is finished I need to upgrade the Mega Fuse, lol where the hell do you find one of those when the UK is in total lockdown ................

On a hunch I went and stripped the Pre Fuse Box (under the right side foot-well carpet) from the W220 Donor a few minutes ago, and lo and behold, same design Mega Fuse but 60 Amp :) ....



I've just installed that in the R170's Pre Fuse Box, so Coffee time, then mass clear up and get out the SDS for a play ;)

Back Soon :)
 

·
Registered
2009 E350 4M Avant Garde, My Mistress 2002 S600, Wife 2014 C300 4M Avant Garde with AMG
Joined
·
986 Posts
yep, my 2002 S600 V12 does
 

·
W220 Moderator
Joined
·
6,365 Posts
Discussion Starter #370
Yes, I have one of those in my shed, trouble is you wouldn't get the Bonnet shut on an R170 Conversion 🤣

A very quick update,

Some Pics and Video soon :)

Cooling Fan working fine, actuates at all the percentage tests, and then after running the Engine up for about 40 minutes it finally cut in around 93 degrees C at slow speed then shut off repeat, so that's another tick ..................

Cooling Fan Sorted ✅
EGS52 Custom Coded TCU fitted ✅

The Coolant and EML Lights a couple of days ago was indeed just a Fan Code due to it not being connected up back then, no other Codes in ME2.8 ECU or any other Modules *(except HVAC), and the Engine sounds sweet as a nut :)

* The HVAC stubbornly still has the (F) Code for the Electric HVAC Coolant Pump, despite the fact that the old one never worked and now the new one does, further SDS testing revealed a text box stating "For 3 button HVAC Controllers this code can be ignored" .................
Yep, you guessed it, my Car has the 3 button Controller DOH !!

@Deplore , @Paul600600 Got any ideas on this next bit .......

2 SDS Machines in Developer mode for some reason will not carry out the few remaining Version Codings in ME2.8, they keep reverting to stock R170 V6 ones, I'm obviously having a Brain Fart and doing something wrong, so will crack on with other jobs and chew on why that is happening.......................

It says it has coded the Diff Ratio and 600 Watt Fan, but after coming out of Developer, and then re reading the Version Codings, they are still showing as stock V6 Codings ..................... I DUNNO right now and as the Fan is working fine, it is probably not that important, but it is to me, cos I know it's set wrong :ROFLMAO: ...................
I had no problem using Developer to do all the other Version Codings waaaaaay back when ???????????????????????????????????????????????????????????????????????

I'm now starting on working my way backwards along the underside of the Car .............

Front Anti-Rollbar Spacers

Exhaust System

Diff Swap

Are all next on my agenda :)

TTFN,
 

·
W220 Moderator
Joined
·
6,365 Posts
Discussion Starter #371
I haven't done much Customer stuff this week to be honest, I am just doing 2 Customer Cars a week now, there are enough here to keep me going to end of April, all big money jobs, 5 left to do ;)
Not taking any more in until at least the end of April, or once Phase 1 of SLK V8 is finished lol ;)

Here's a few photies from yesterday ....

Trans EGS52 Custom Coded TCU installed ....





Some SDS Shots, No Faults showing now, (except that HVAC anomaly), and the Fuelling / Idle / Lambda figures are all as they should be and in the middle of their tolerances :D :D :D ....







My "Top Secret" Cold Air Intake is now revealed, got to replicate this on the other side, waiting on a "Remote Type" PAS Reservoir to mount on the Left Inner Wing, because the stock V8 one atop of the PAS Pump gets right in the way of me posh new Air Intake :( ....





Back soon with more updates ;)
 

·
W220 Moderator
Joined
·
6,365 Posts
Discussion Starter #372
Hi again,

Coffee break, another one of my rubbish videos, did this yesterday, the darned ting is well out of Focus, basically I had the Fan running on SDS with Engine Off, you can maybe's just see it moving when I started filming it at 20%, then went back to SDS and stepped it up to 90% you can hear it roaring as it gets faster on the sound track, then the Batteries on the Video Camera died !! ....


One word .............. SH1T !!

I think I will give up with the Videos, there isn't really much point in doing them if I gotta type out chapter and verse of what's going on 🤣 🤣 🤣

TTFN
 

·
Outstanding Contributor , SDS Guru
1998 MB E300TD, 1997 MB E36 AMG, 2001 MB E55 AMG
Joined
·
3,671 Posts
Are you cycling the ignition when you reread the version coding?
 

·
W220 Moderator
Joined
·
6,365 Posts
Discussion Starter #374
Hi @Deplore,

I think I tried that, but don't recall for definite, will try and find time for another go in a while before I pack up tonight ;)
 

·
W220 Moderator
Joined
·
6,365 Posts
Discussion Starter #375
OK, ok, go on then, now look what I've done ................



It's gonna have tiny little Stainless Torx Button Head Screws in the 6 "rivet holes" around the 'B' Logo, when I actually find where I put the box full of M4 Stainless Screws / Washers / Nuts :D

Trouble is now I gotta clean everything else in the Engine Bay ;)

The other new "Top Secret" bit is exactly what I'm going to do with the Silver "Mercedes - Benz" Trim up the Centre of the Air-box ................................

I guess everyone following this project will all just have to wait and see 😈

Chow for now :)
 

·
Registered
Too many to list
Joined
·
8,822 Posts
looking great ! To replicate the brabus engine cover you need the red center section and the brass plate (which a trophy shop can make )
2625563
 

·
W220 Moderator
Joined
·
6,365 Posts
Discussion Starter #377 (Edited)
Thank you @tusabes ,

That is exactly what I intend to do, you guessed my latest "Top Secret", I was actually gonna go back through and find those pics you showed me of your Brabus, so I could confirm exactly how the Red Centre trim was done !!

Also will do the Red Cam Covers, glad I haven't done the Gaskets and Breather Job yet :)

Would it be too cheeky to ask you for a close up piccie of the Brass Plate and the size measurements of it ? Then I can get it done with my Engine Number on it, can pm if you like ;)

Cheers 🍺 🍺
 

·
W220 Moderator
Joined
·
6,365 Posts
Discussion Starter #378
Here's some update pix from yesterday ....

Who can guess what these are ? ..........................................

Oh, OK then ;) , they are Spacers for the Front Anti-rollbar Mountings ....



And the reason for these is 2 fold, firstly, when the suspension is on full Droop, as it is whilst on my Lift, this Sump Bolt almost touches the Anti-rollbar, in the Pics below, the Spacers are fitted, so without them it is even closer, definitely hits when traversing "Speed Bumps" etc ....



This is the clearance it has now, as the Suspension compresses it travels further away, and a pic of where they are installed between the Mounting Saddle Brackets and Chassis ....





They also have the added bonus of being an "Anti Dive Kit as they have the effect of stiffening up the Front Anti-rollbar, so jobs a good un ;)

Anti-rollbar Spacers fabricated and installed ✅

Then I had a little Play, testing stuff, Car on the Lift, Wheels in the air :D

Speed LIM sets as it should, so that means Cruise Control will work too :) ....



TCU is working in Manual Mode, shifts to 1 and up with Paddles and Tippy Stick :) ....



Increase the revs a bit and the Traction Control cuts in as it should :) ....



So that's more good news, all that stuff is working as expected, no nasty surprises there then :p

So left to do before the initial Road Test is Exhaust System and Diff .................

I'm on the Exhaust system today, as usual it is going to plan but taking longer than expected, then I got to pull it all off again and give it a good coat of Cold Galvanise Paint, it does help up here with all the Salt, even though the pipes are mostly Stainless, I don't have Stainless Welding Facilities and also some of the Joints and Hangers are Mild Steel, gotta use what I got, or there will be a big delay ;)

Exhaust should be finished by tomorrow, just leaving the Diff, which I'm gonna partially strip to check it out as it was an EBay Breakers Yard unit ;)

C ya'll soon ;)
 

·
Registered
Too many to list
Joined
·
8,822 Posts
Mine does not have the brass plate , the best pics I can find are here
2625660
 
361 - 380 of 410 Posts
Top