Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
1987 560SEL, 1988 300E, 1989 300SE
Joined
·
12 Posts
Discussion Starter #1
Well, actually Tacoma, but close enough. I have a three stall garage and all three stalls are filled with MBs. We own an 87 560SEL (my car) an 89 300SE (wife's car) and an 88 300E (sons car). I am relatively new to working on MBs but am learing quickly. Sons car works perfectly now. Wife's car works perfectly now. Still trying to fix the high idle problem on mine, but when that is fixed, mine will be working perfectly. I've got lots of questions, and am certain that my MB stupidity will show its ugly face, but for those willing to be patient with me, I'm a quick learner. I have become a rabid fan of MB and will probably never own another type of vehicle with four wheels. Of the two wheeled variety, I am a proud Harley dude. Look forward to swapping ideas in this forum for years to come.
Blessings;
JD:)
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,633 Posts
JD, welcome aboard.

Please click the User CP link and complete your BW profile re: vehicles and location as that is often useful information.

The folks in the specific forums for your car(s) are quite knowledgeable and I'm confident they'll be able to help you to the root of the non-perfect issue. :)

(My two wheeled variety is a V-Twin as well, but Italian, not American.)

Take care and enjoy the ride,
Greg
 

·
Registered
1983 300D Turbo Diesel
Joined
·
1,799 Posts
Welcome to Benzworld!
 
1 - 4 of 4 Posts
Top