Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
98 sl500
Joined
·
6 Posts
Discussion Starter #1
O.K. I get the stupid awar don't I? I was washing the my wife's 1998 Sl 500 and I decided to put the top half down so I could clean the areas that are otherwise hard to get to. I turned the key to position 2 and actuated the lowering switch. Less than half way down I turned the key off and removed it. Immediatly the top came back down in the front and the rear stayed up. I cleaned the rear portion then folded the cover down and lowered the back portion of the soft top into the holes for the pins. I then put the key in and pushed up on the soft top switch and it locked into place. Now the soft top switch and both lights on the roll bar switch stay illuminated regardless of what I do. Neither will function.

I tried removing the fuses from the trunk and under the hood to reset; no luck. Even disconnected the battery without any luck. Tried the resync as mentioned in owners manual for windows. Nothing. What could the problem be? I would think some sort of safety feature has been activated.

I drove the car to the dealer without any problem. We will see. In the mean time any advise? I don't want the dealer to feed me a line of BS that I need some major rebuild if it might be something simple.
 

·
Registered
S500 W220 - A190 W168 - SL320 R129 (SOLD)
Joined
·
23 Posts
I know the answer due to same thing happening to me!!

Snice


I had a similar problem where my roll-bar button and hood button stayed illuminated. It turned out it was the battery running low and anything to do with the battery throws the roll-bar and hood functions out. If the car is jump started or battery replaced etc or low, it does this.

I had to go to a MB Service Station and hook up to their laptop software where they reset the memory error codes which solved the problem straight away but needed a new battery.

Basically, your battery is running low.

Thanks

Kevin
 

·
Registered
98 sl500
Joined
·
6 Posts
Discussion Starter #3
Re: I know the answer due to same thing happening to me!!

Snice


I had a similar problem where my roll-bar button and hood button stayed illuminated. It turned out it was the battery running low and anything to do with the battery throws the roll-bar and hood functions out. If the car is jump started or battery replaced etc or low, it does this.

I had to go to a MB Service Station and hook up to their laptop software where they reset the memory error codes which solved the problem straight away but needed a new battery.

Basically, your battery is running low.

Thanks

Kevin

Well, I wish you were right. I took it to the dealer yesterday and the service computer could not get any codes out of the computer. They put a new computer in and all worked fine. $3,300 for the part plus labor. Can you say bend over!
 
1 - 3 of 3 Posts
Top