Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
SL 320
Joined
·
19 Posts
Discussion Starter #1
HI there

I had a really strange problem with my SL. It had been laid up for approx a month. I drove it off the drive and afterwards noticed spots on the floor leading to the back of the car. I started the car up and saw fuel dripping from the can surface of the fuel filter. After rining the AA they turned up about an hour later and I could not simulate the problem. Both the filter and pump were bone dry and there was no sign of a leak anywhere.

I was just wondering if anyone else has experienced a similar problem. Or is there a vent on the fuel filter which vents fuel after its been laid up for a while. I am very reluctant to use the car now. The fuel filter was changed about three months ago with a genuine MB one

Regards

Stu
 

·
Registered
Departed 1998 SL500 (and the Pano is in Bogota)
Joined
·
11,118 Posts
Are you sure it was fuel and not some other fluid ?
 

·
Registered
SL 320
Joined
·
19 Posts
Discussion Starter #3
Yes it was definately fuel. Some dripped onto my hand and it smelt like fuel and evapourated.
 

·
Registered
1999 SL500 Sport, Black Opal Pearl, Helios Leather, Pano roof, AMG Aero2 18"Split Rims, Rear Seats
Joined
·
1,215 Posts
I had the same thing a good while ago. The factory clamps are not that good and one of the fuel pipes was leaking at the join to the filter. Get some new worm drive clamps and swap them over or check for tightness if they were change with the filter. Its under a plastic cover in front to the inside of the RH rear wheel. You will need a 10mm 1/4drive socket with an extension from recollection.
 
1 - 5 of 5 Posts
Top