Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2009 SL550 Silver Arrow Launch Edition, 2013 Mercedes Benz C300 4Matic
Joined
·
986 Posts
Discussion Starter #1
I am aware of the "normal" shift delay from 1st gear and beyond when the engine is cold. I can usually predict the approximate location in my neighborhood when it will start shifting up as it warms up. But today, I never got out of 2nd gear as I was on my way to have a check engine light checked out at dealer. I was almost there (about 5-6 miles away) stopped for a red light, put it into "Park" and back into "Drive" and it shifted fine from that point on. Dealer thought the "shifter" could be the reason for the check engine light (?).
Thoughts anyone?
 

·
Registered
Joined
·
75 Posts
The failure to upshift could be as simple as a stuck kickdown switch. If the problem continues, you might try disconnecting the cable between the switch and the transmission from under the car.

I don't think the shift problem could be related to the check engine light. I really don't understand why the dealer is speculating -- didn't they get the codes from the diagnostic module? It only takes a couple of minutes. And it is something that anyone can easily do themself with a $2 LED from Radio Shack.
 

·
Registered
2009 SL550 Silver Arrow Launch Edition, 2013 Mercedes Benz C300 4Matic
Joined
·
986 Posts
Discussion Starter #3
Thanks. Dealer ran test and codes lead them to test the EGR & Transmission upshift solinoids. They tested and repaired them for me @ N/C. I had throttle body harnesses replace recently and they feel as though a connector (as above) was the cause of both the check engine and trans. shift problem. All is fine now.
 

·
Registered
1992 400E
Joined
·
11 Posts
Arn't those dealers the nicest people. [:D] I really mean it. I don't know of any other manufacturer that treats you like a Mercedes dealer. They wash your car, give you a free loaner while yours is being worked on, and you can trust them to do exactly what is necessary to fix the problem.

On another note, I just bought a 1999 SL600![^] YEA!
I paid $32,000 for it on EBAY. I had a local Mercedes dealer check it out for me for only $95. For a peak, you can see it here...

http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&item=4527501908&rd=1&sspagename=STRK%3AMEWA%3AIT

I am glad that every thing turn out well on your check engine light!
 

·
Registered
2009 SL550 Silver Arrow Launch Edition, 2013 Mercedes Benz C300 4Matic
Joined
·
986 Posts
Discussion Starter #5
Hey, you got a nice one there socalmat! I watched that one go. Glad you like it and good luck with it. I have ad mine not quite a year yet, and am casually looking for something either 2000 or 2001 for my next one.
 
1 - 5 of 5 Posts
Top