Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
SL600
Joined
·
3 Posts
Discussion Starter #1
Hi, just wondering if anyone out there has had any experience with this system. I get the ADS lite on intermittently, and the ride does seem kind of "bouncy" at times. It doesn't seem to be consistent though. Turning the key off and on again puts the light out for awhile, but eventually it comes back on. Thanks
 

·
Registered
sl600
Joined
·
2 Posts
sl 600

Hello there,
I had problems with my suspension on my sl500 and had to replace the actuators. This corrected the problem that i had. You must use only MB fluid in the refill or this can also cause problems with the system. Good luck RIck
 

·
Registered
Joined
·
8 Posts
the suspension on the 500 and the 600 are different. The 600 as the ads with a switch on...

the suspension on the 500 and the 600 are different. The 600 as the ads with a switch on the left side of the steering to adjust the damping mannually to confort or sport buy lowering the shock or the other way. They are know to break with time has the car is really heavy. Fairly expansive to repair from what I have heard aldo, I've never experience it myself. I would advise you to have it checked up before damage is caused. I've hear do that when they go out, the suspension set itself to sport automaticly.
Hope this helps.
 

·
Registered
2000 SL600
Joined
·
14 Posts
SL600 ADS Issues

My Sl600 had same problem--first check showed that Fluid REsevior was low on MB Hydraulic Oil. There is NOT an aftermarket replacement for that fluid !!!

Thankfully my car is still under warranty. THere was a fluid leak at one of shocks and dealer replaced ($1200 part +labor) under warranty.

Be careful--many folks will recommend Petosin fluid as alternative to MB fluid. DO NO USE---IT will destroy hases, seals and pump in system--so I've been told. Dealer said total repair would have cost $5000 and pump running low on fliud would cause total failure of system--
 
1 - 4 of 4 Posts
Top