Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
My 2006 Mercedes CLS 500 is equipped with Sirius Satellite Radio. I would like to activate this feature. When I press SAT on the radio keypad, a msg. appears that says No Satellite Radio. The car is equipped, however. How can I get the radio ID code so I may activate the Sirius service? Thanks.
 

·
Registered
Joined
·
558 Posts
I added this feature to my car(06 C55) the radio code was on the small reciever box that I installed, and it would show up under info on the command screen when I pressed the sat button. It is possible that the car hasnt been version coded for the optionor the reciver isnt working correctly. I would say until you can get the command to recognize the feature you will not be able to get it to programm from sirius.
 

·
Registered
Joined
·
73 Posts
I installed the Sirius option on my CLK500 cabriolet and had several issues during install, all of which worked out. The fuse has to be installed and the MOST cables have to be connected. At that point the rest of your sound system should work and you should get a display that shows you the ID and a phone number to call. If you don't have the fuse installed with the MOST cables connected you won't get sound. If the fuse is installed but the MOST cables aren't connected I think it will say the Sirius is not installed. So both must be there.

Good luck.

Steve
 

·
Registered
Joined
·
7 Posts
I installed the Sirius option on my CLK500 cabriolet and had several issues during install, all of which worked out. The fuse has to be installed and the MOST cables have to be connected. At that point the rest of your sound system should work and you should get a display that shows you the ID and a phone number to call. If you don't have the fuse installed with the MOST cables connected you won't get sound. If the fuse is installed but the MOST cables aren't connected I think it will say the Sirius is not installed. So both must be there.

Good luck.

Steve
Steve,
I have a 2005 CLK320 cab and retrofitted a Comand APS with Navigation, but the navigation is not functioning properly. I don't get the esn number or the preview channel. Could you give me more detail on what you did to your CLK500 to make it work?
Thanks,
Mike
 

·
Registered
Joined
·
73 Posts
You actually say two different things here. You retrofitted a COMAND APS Nav unit and it's not working. Then you talk about the Sirius Satellite radio. These are two different things. Are you sure Sirius is installed? It's a unit separate from the nav unit and would normally be installed under the raised shelf at the frontmost part of the trunk. It took a while for me to find that out.

Do you have an antennal installed for the GPS? you need a GPS antenna or it won't receive the satellite signals and it won't show you your position.

Good luck.

Steve
 

·
Registered
Joined
·
7 Posts
I know my post was confusing. I tried to fix it after it posted, but failed.
Anyway, the Navigation is working. I do have a GPS antenna, although I have to work on finding a good place for it, since the recommended places are not giving me a good signal.
When I select the SAT button on the nav unit, I just get a pretty much blank screen with no options.
Now after I read your response, it looks like I need a separate satellite receiver in addition to the fuse and MOST configuration. I thought the satelitte stuff would be inside the nav unit, for the amount of money it costs. :mad:
 

·
Registered
Joined
·
26 Posts
I know my post was confusing. I tried to fix it after it posted, but failed.
Anyway, the Navigation is working. I do have a GPS antenna, although I have to work on finding a good place for it, since the recommended places are not giving me a good signal.
When I select the SAT button on the nav unit, I just get a pretty much blank screen with no options.
Now after I read your response, it looks like I need a separate satellite receiver in addition to the fuse and MOST configuration. I thought the satelitte stuff would be inside the nav unit, for the amount of money it costs. :mad:
You'll need to install the factory SDAR (sat receiver) or use the iTronic solution for your car to get the sat radio. For the factory solution you'll also need another arm and leg. The iTronic after market solution isn't cheap either but less painful than the Dealer.
 

·
Registered
Joined
·
7 Posts
You'll need to install the factory SDAR (sat receiver) or use the iTronic solution for your car to get the sat radio. For the factory solution you'll also need another arm and leg. The iTronic after market solution isn't cheap either but less painful than the Dealer.
That settles it, no SAT radio for me. :surrender: Even with the itronics module I am still losing an arm ($799). Plus I would still have to pay a month fee for the Sirius subscription.
Thanks to all for your input.
 

·
Registered
Joined
·
28 Posts
Hello steve,

Which slot has the sirius fuse? How would I connect the most lines? 2005 clk320. I installed sirius (unit) behind rear seat but no sal displays on the command radio,

James
 
1 - 11 of 11 Posts
About this Discussion
10 Replies
7 Participants
jjday
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top