Mercedes-Benz Forum banner
1 - 10 of 10 Posts

·
Registered
1998 Mercedes C230
Joined
·
44 Posts
Discussion Starter · #1 ·
My check engine light went on and the car shakes a lot when idling and at low speed. The only code that is showing up is p0303. Before I buy new spark plugs I want to find out if the problem is the plugs or the spark plug boot. What spark plug boots can I swap to see if the misfire will happen in another cylinder?
 

·
Registered
1998 Mercedes C230
Joined
·
44 Posts
Discussion Starter · #5 ·
Thanks for responding Triggerhappy, I check them out and they are fine, I also swapped 2 of the boots to see if the one on the third cylinder was bad but still have the issue. Any suggestions for other things I could try or possible problems?
 

·
Registered
1998 C280
Joined
·
16 Posts
I ended up replacing all the coils in my 98 C280. The car lived in the heat of S Florida for years and was transplanted to the Northeast. Would get misfires if the coils got wet or if the car sat in high humidity for a couple of days. Suspect the plastic matrix around the windings had micro cracks and once water got in they were dead. Also replaced all the plugs and wires along the way.
 

·
Registered
1998 Mercedes C230
Joined
·
44 Posts
Discussion Starter · #10 ·
Thanks for all the help, figured out it was just one of the of the coil's and the car runs even better now. Seems like it was misfiring for a while because the spark plug in the 3rd cylinder was not even close to as worn as the other 3.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top