Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1989 Mercedes Benz 560SEL
Joined
·
25 Posts
Discussion Starter #1
ok here are a few of the stupid little things my 560SEL bugs me with

1. turn signals work without headlights, but when lights are on, only my right signal works and the left one just stays on.

2. intermittent miss in engine, plugs are new and wires look fine to me. although one was arcing on header once before.

3. dashlight behind gauges dont work?

4. and my biggest worry was what looked to be a few smudges of oil in the air fliter pan???

i know to a seasoned benz owner these are probably basic, but im new to german engineering so any help would be excellent.
 

·
Registered
1987 420SEL
Joined
·
1,133 Posts
1- Replace every single fuse in the fuse box and see what happens. Wire-brush the contacts, or use emery cloth on them. Blow/clean out thoroughly prior to installation of fuses. Fuse packs are $9 from the dealership; you'll need about 4.

2- Inspect the entire length of the wires to ensure they're not bundled together too closely at any specific section and make sure the plastic wire holders are being used. Leave this to later if everything checks out.

3- See #1, if not rectified, remove cluster (simply pulls out; forum search) and replace the bulbs as well as clean the contacts for the dimmer knob.

4- Don't worry about it; your signals don't work, you've got bigger fish to fry.:thumbsup:
 

·
Registered
1989 Mercedes Benz 560SEL
Joined
·
25 Posts
Discussion Starter #3
bigger fish to fry is right. engine will crank but not start. it just sputters now. so is this the end or is it something stupid?
 

·
Registered
1987 420SEL
Joined
·
1,133 Posts
There's gas in it, right?

A forum search will yield a ridiculous amount of information on diagnostics for these cars. Your issue may be fuel related, so isolate the problem by checking the fuel pump operation by jumpering the relay yadda yadda yadda.

Then check out the ignition systems. Fuel issues are more common, from what I've seen, than electrical.
 

·
Registered
1989 Mercedes Benz 560SEL
Joined
·
25 Posts
Discussion Starter #5
im almost certain theres gas in it lol, the gauge says its half full but with my luck thats probably busted too
 
1 - 5 of 5 Posts
Top