Mercedes-Benz Forum banner

21 - 31 of 31 Posts

·
Registered
1997 E320, 1997 S320
Joined
·
2,946 Posts
Ok so i just had hooked up to a mercedes benz scanner (believe it was coach scanner) to pull the transmission codes n it said no faults found. So no codes what so ever. So whats next? Could it be due to the atf i got from benz which is designed for newer 7spd auto transmission?

Pls let me know your thought.

Cheers,
Farhan


Sent from Farhan's iPhone 4

it is not the fluid you got from mb. actually mb uses that fluid in all 722.6 trannies. the fluid you used is "the approved" fluid. i have the 236.14 fluid (same as yours) in one of my 722.6 and valvoline maxlife in the other 722.6 and both shift fine.
did this hard downshift start recently or did you experience it since you got the car? how hard of a shift do you mean, like a thump? when you are slowing down are you pressing on the brakes at all or just cruising?
 

·
Registered
2002 e320
Joined
·
344 Posts
I have this same symptom. I would like to know how I can check if it is the brake booster. For one thing, I have no clue what a brake booster is or where it is located. So any help would be great.
Paul
 

·
Registered
2010 E350 4matic
Joined
·
325 Posts
Discussion Starter #24
Hey tirona,
Thanks for your reply bud, and everyone else..much appreciated.
I was actually reading that whole thread yesterday. Ive been searching the net for break booster vaccum line leak all day with no success. I really wana look at the break booster next because if it was the bad speed sensor it would have thrown code and there is no code at all. The car does feel a bit heavy as if its running with the parking break engaged but let me assure it thats not the case:) anyways at this time i think i do need to look at the break booster so if anyone has any material on that i'd really appreciate it. Thanks

Cheers,
Farhan
 

·
Registered
1997 E320, 1997 S320
Joined
·
2,946 Posts
brake booster is located right behind the brake fluid reservoir, it;s that round and big metallic "bowl" thingie. the booster gets vacuum from the engine and through vacuum force pushes the fluid from the master cylinder to the calipers. without the brake booster it will require a lot more force to push on the brake pedal to stop the car.
the swedish member who reported the brake booster vacuum leak did mention that the rpm's would slightly fluctuate after he quickly pressed/depressed the brake pedal. he mentioned that his mechanic told him "He told the that the engine got extra air from the brake booster, so that's why its running rich, and the jerky gear changes."
you might want to ask a mechanic or someone who is familiar with the brake booster. hopefully someone here with wis can post some diagrams.
 

·
Registered
2010 E350 4matic
Joined
·
325 Posts
Discussion Starter #26
brake booster is located right behind the brake fluid reservoir, it;s that round and big metallic "bowl" thingie. the booster gets vacuum from the engine and through vacuum force pushes the fluid from the master cylinder to the calipers. without the brake booster it will require a lot more force to push on the brake pedal to stop the car.
the swedish member who reported the brake booster vacuum leak did mention that the rpm's would slightly fluctuate after he quickly pressed/depressed the brake pedal. he mentioned that his mechanic told him "He told the that the engine got extra air from the brake booster, so that's why its running rich, and the jerky gear changes."
you might want to ask a mechanic or someone who is familiar with the brake booster. hopefully someone here with wis can post some diagrams.
Thank u so much for that info Tirona. I'll check it 1st thing in the morning. I know for a fact that the break padel requires quite a bit for force for the car to stop and i get a slight viberation when i get to close to stoping so it might very well be the break booster. Seems like alot of folks are facing this funny shifting issue so i'll check it out tomorrow and report back for everyone else.

Once again guys (and tirona) thanks alot for the help!!

Cheers,
Farhan
 

·
Registered
Joined
·
103 Posts
The Downshift at 3000rpm as been getting worse day by day :(

I've also noticed that when I do an acceleration (but not with the kickdown), the engine tends to choke for a sec when it crosses the 3000rpm stage...

I also mentionned earlier in this forum that I had the transversal acceleration sensor that is supposed to be changed (although after the odb reset the car seems to be ok)...

I'm a bit confused coz the car has 150k (1st owner), but with all these things, i'm thinking of getting rid of it...
 

·
Registered
Mercedes E200 Auto w210
Joined
·
7 Posts
I had the same problem changed out the brake booster and the car runs a little better, now I can drive around a 100km further. My car is at my local MB dealer as we speak and they called me for about 5 minutes ago and told me that the plug for the transmission is leaking oil, so thats the problem they told me. so, they're changing it out as we speak. He told me that they needed to change the transmission oil to, when they change the plug, is this true? I changed the oil last summer, feels like waste of money.

its going to cost me 910dollars/656euros. I dont really cares what it costs anymore I just want the ruff shifting to stop.

Thank you.
 

·
Premium Member
2001 E320 - Brilliant Silver/Ash: 107,000+
Joined
·
17,193 Posts
910 dollars is way too much money for a transmission service. It sounds like all they need to do (after replacing the leaking connector) is add enough fluid getting the level back to normal.
 

·
Registered
2010 E350 4matic
Joined
·
325 Posts
Discussion Starter #31
sorry guys i still haven't had a chance to look at break booster vacuum line leak to see if that helps but i'll look into it this w/e and report back for everyone. I did however notice that there seem to be some kind of a sound coming from near the engine block sounds like air is leaking (almost like when you take air out of your tire) and gets louder if you rev it. IT Comes from right side of the block somewhere near the header but the headers are not leaking i checked while it was on the hoist from under the car.
 
21 - 31 of 31 Posts
Top