Mercedes-Benz Forum banner

1 - 20 of 23 Posts

Registered
Joined
24 Posts
Discussion Starter #1
Dear W220 friends

I have a fault in my Comand code B1779 (Active Fault in CAN communication with TV Tuner)

I have no audio on Radio, low volume on CD

I have had it on star diagnostics where it seemed to configure the TV tuner.
The TV tuner seems very hot all the time, I am wondering if it is faulty? It is positioned above my CD changer. (See picture)
I do not see any orange fiber optic connection and it is not listed on the onboard Comand diagnostics, I only have 3 pieces of hardware listed below

I have these three items listed 1x 1C8 Comand unit 1x 190 CD changer, 1x 0F0 Nokia mobile

I am guessing the TV tuner is the reason I have no audio? Can anyone confirm this?
It is analogue anyhow and no longer much good and maybe faulty, how can I remove it safely, after unplugging it the fault code remains?

Any help or advice is very welcome
Cheers Martin :)
 

Attachments

W220 Moderator
Joined
5,539 Posts
Hi,

These old Analogue TV Tuners are as you say, completely useless now, and they cause a lot of bother.

Disconnect it completely and remove it from the Car !!

I can't remember now, does it have Fibre Optic going to it ??

If so take it out of the Fibre Optic Loop, you may need a connector to avoid breaking the F/O loop, configure the Loop in COMAND so TV is not present, although from what you say it is already configured that way ;)

Finally, chuck it in the trash :grin

HTH,
 

Registered
Joined
24 Posts
Discussion Starter #3
Hi Dave

Thanks for the reply!

I have unplugged it for the time being, but the fault code remains.
I cant see the obvious orange fiber optic cable anywhere, not too sure if it should have one?
I have the car booked in on Monday for the Star Diagnostic scan specifically for the COMAND. I will ask them to take it out of the system completely and see if it will finally resolve my volume issues or at least be a step closer.

Cheers Martin :)


Hi,

These old Analogue TV Tuners are as you say, completely useless now, and they cause a lot of bother.

Disconnect it completely and remove it from the Car !!

I can't remember now, does it have Fibre Optic going to it ??

If so take it out of the Fibre Optic Loop, you may need a connector to avoid breaking the F/O loop, configure the Loop in COMAND so TV is not present, although from what you say it is already configured that way ;)

Finally, chuck it in the trash :grin

HTH,
 

Registered
Joined
24 Posts
Discussion Starter #4
Update:

I have a no audio problem on tape/radio and low volume from the CD changer.

I had the car back in the garage and hooked up to the MB Star diagnostics and decommission the TV Tuner from the Comand system because it was previously showing fault code B1779 (Active Fault in CAN communication with TV Tuner)

The TV was decommissioned/removed, and still the audio issue remains!! So i thought why not remove the telephone from the Comand also, as that maye why the ring is open... So the telephone was decommissioned/removed and still the no/low audio issue remains?

I have no fault codes in the Comand diagnostics but the ring remains open?? I really do not understand... Do i still need to close the fibre optic loop from the Telephone system even though it has been removed via MB Star?

If so where is the phone located as it is not in the boot of my car? I am running out of options please help if you can?

Cheers Martin
 

Registered
Joined
4,183 Posts

Registered
Joined
24 Posts
Discussion Starter #6
Thanks so much for the reply and information, I will do that as soon as I can find the optic loop cable on the telephone system, any idea where the phone system is on my Euro 320CDI pre-faclift?? It is not in the boot/trunk area...

Cheers Martin

Yes, you do need to close the fibre optic loop. Here's what you use for that. Available from the stealership for about US $5.00.

https://www.mboemparts.com/oem-parts/mercedes-benz-adapter-0005453384

And the explanation.

https://www.benzworld.org/forums/audio-telematics-forum/1399151-2000-s500-w220-chassis-how-bypass.html
 

W220 Moderator
Joined
5,539 Posts
Phone System is designed to Mute Audio as a call is made / rec'd ....................

And when it goes faulty it sometimes mutes it permanent ......................

If you are not using this now antiquated eqpt it might pay to get rid of that too ;)
 

Registered
Joined
24 Posts
Discussion Starter #9
I may well do that Dave, once I find its location! :)

Cheers Martin

Phone System is designed to Mute Audio as a call is made / rec'd ....................

And when it goes faulty it sometimes mutes it permanent ......................

If you are not using this now antiquated eqpt it might pay to get rid of that too ;)
 

W220 Moderator
Joined
5,539 Posts
I may well do that Dave, once I find its location! :)

Cheers Martin
As @wallyp said, their is equipment in the Centre Console, remove that, then follow the wiring under back seat base, right side of Car, and that is where the actual phone module resides.

Remove all the redundant Wiring as you go, but leave the antenna Wired all the way to the Centre Console, you can plug a repeater antenna into it for good cell reception inside the Car if you wish, that's what i did, my Cell Phone is Bluetoothed to my Android Head Unit :wink:

HTH,
 

Registered
Joined
2,388 Posts
I use a Wilson antenna booster to improve cell performance, and discovered that the Wilson will not work with the shark fin antenna. If the cell antenna is within a couple of feet of one of the windows, the booster goes into a feedback loop, and instantly shuts down to keep it from frying the electronics.

I transferred the line to the rear bumper antenna, and the system has worked well for several years.
 

W220 Moderator
Joined
5,539 Posts
I put my Booster under the Centre Console Cubby Box, completely out of sight with 3M double sided tape.

Works a treat, never had an issue, it was just a cheapo EBay one but Cell Phone reception improved drastically once I installed it, beforehand it was weak at best, now almost always full scale on the signal bars :)

Mine is just an internal Repeater Antenna, wired to the original CoAx in the Console. It doesn't have any amplification per se, I leave that to the stock MB Antennae Amp ;)
 

Registered
Joined
24 Posts
Discussion Starter #13
Thanks Dave for the confirmation I will tackle that once these temperature drop a bit. Thanks for the tip ref the aerial I will do that also.

PS: I will probably go the Android root in the end, but I want to drive the car with the comand system working, then, at least then I will have a comparison.

Cheers Martin

As @wallyp said, their is equipment in the Centre Console, remove that, then follow the wiring under back seat base, right side of Car, and that is where the actual phone module resides.

Remove all the redundant Wiring as you go, but leave the antenna Wired all the way to the Centre Console, you can plug a repeater antenna into it for good cell reception inside the Car if you wish, that's what i did, my Cell Phone is Bluetoothed to my Android Head Unit :wink:

HTH,
 

W220 Moderator
Joined
5,539 Posts
Hi Martin,

LOL, I did all that, spent about 拢500 getting all COMAND systems working, and then ended up fitting the 拢300 Android + all the extra goodies like TPMS, Head Rest DVD's, Rev Cam, USB Data Transfer Socket etc etc etc.

Myself and others (who have actually wired them up correctly) will confirm it is waaaaaay superior and makes the Interior of the Car look much newer in styling than the old dated D2B COMAND H/U :wink

HTH,
 

Registered
Joined
24 Posts
Discussion Starter #15
Hi Dave

I have probably already spent too much time and money trying to resolve the Comand no/low audio issues, but I have also learned a lot more on how the Command system actually works, some do say the journey is where the fun is not only the destination! :)

Regarding the Android head-unit, I have started reading up on the matter. I suppose my apprehension is I do not really have the time/knowledge/opportunity to fit the head-unit myself and I afraid a third party vendor may mess up the install. (Things like that seem happen a lot in this part of the world)
So it may take a while for me to gain the knowledge and confidence or find a trustworthy vendor to undertake the instal. That is once I determine which head-unit to buy. I think I will get there eventually :)

Cheers Martin



Hi Martin,

LOL, I did all that, spent about 拢500 getting all COMAND systems working, and then ended up fitting the 拢300 Android + all the extra goodies like TPMS, Head Rest DVD's, Rev Cam, USB Data Transfer Socket etc etc etc.

Myself and others (who have actually wired them up correctly) will confirm it is waaaaaay superior and makes the Interior of the Car look much newer in styling than the old dated D2B COMAND H/U :wink

HTH,
 

Registered
Joined
24 Posts
Discussion Starter #16
AN UPDATE:

Well i thought it only good manners to update on my audio issue...

I ordered the MB adapters for the fiber optic cables, it was a non stock item, eventually they arrived. I found the phone module under the rear seat as previously described. I unplugged the fiber optic cable and closed the loop using the adapter (please see photos) Unfortunately still no audio, I am out of ideas, I guess the head unit could be knackered?? I spent such a long time trying to sort this out...
I even tried a loop adapter on the CD changer, I was quite sure that would not resolve anything and it did not. I quickly reconnected the CD changer, I still
2602660
have low volume only and still no audio on radio etc. And he loop
I would probably be prepared to bite the bullet on an Android audio upgrade but I have a nagging fear I may still have low volume issues??
2602657
2602658
2602659
 

W220 Moderator
Joined
5,539 Posts
Likely Head Unit or Bose Amplifier if you have Bose, if you do not have Bose fitting an Android ERISIN is really easy, all connections are behind dash, you could easy do that with a little help from your friends here ;)

HTH,
 

Registered
Joined
24 Posts
Discussion Starter #18
Likely Head Unit or Bose Amplifier if you have Bose, if you do not have Bose fitting an Android ERISIN is really easy, all connections are behind dash, you could easy do that with a little help from your friends here ;)

HTH,
I do not have the Bose amp, and I don't really want to spend money on an old head-unit, so I will probably go the Android route. I cannot find any Android units for my W220 in stock, one company have quoted me 450 euros installed with a months lead time. But information is vague, I have started my research.... It at times like this when I really miss the UK...

Cheers Martin
 

W220 Moderator
Joined
5,539 Posts
Hi,

If you are in USA perhaps @cowboyt or one of the others could advise you on a supplier.
Having seen installs by so called Pro's in UK, my advice to you is to do it yourself, with help from here.

I am one of the only guys here who has done a non Bose Car, it is really easy, and my ERISIN was literally Plug and Play I can help you with that if the info in the stickies is not enough ......................

There is a lot of talk of a 6m Cable wired between H/U and Trunk, you can ignore all that, your Cars Speaker Wiring is at the COMAND H/U behind the Dash, as are the other 3 wires, and 2 CAN Wires, yep, that simple, plug in Speakers, Plug in Earth, Batt + and Wake Up, lastly use the adaptor which comes with the H/U and plug in CAN bus 2 wires 馃槈


HTH
 

Registered
Joined
24 Posts
Discussion Starter #20
Hi,

If you are in USA perhaps @cowboyt or one of the others could advise you on a supplier.
Having seen installs by so called Pro's in UK, my advice to you is to do it yourself, with help from here.

I am one of the only guys here who has done a non Bose Car, it is really easy, and my ERISIN was literally Plug and Play I can help you with that if the info in the stickies is not enough ......................

There is a lot of talk of a 6m Cable wired between H/U and Trunk, you can ignore all that, your Cars Speaker Wiring is at the COMAND H/U behind the Dash, as are the other 3 wires, and 2 CAN Wires, yep, that simple, plug in Speakers, Plug in Earth, Batt + and Wake Up, lastly use the adaptor which comes with the H/U and plug in CAN bus 2 wires 馃槈

[/URL]

HTH
Hi Dave,

I am English but I live and work in North Macedonia and have done for a long time... I greatly appreciate your post and encouragement it is just what I need. I have seen the work of the place here that quoted me and I am also not too impressed, so I am inspired to do it myself.
My problem is not many Ebay sellers deliver here as it is a non EU, including the seller in link you supplied. I have friends coming over in November, but I am not too sure if the head unit would be too big to fetch over, or I want to wait that long. I may try contacting the seller and ask him a favour? I will start some serious searching

Cheers Martin :)
 
1 - 20 of 23 Posts
About this Discussion
22 Replies
4 Participants
Dave2302
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top