Mercedes-Benz Forum banner

1 - 20 of 37 Posts

·
Registered
04 ML500, 98 SLK230, 92 500SL
Joined
·
38 Posts
Discussion Starter #1
Thanks in advance for any help from the community.
My ML developed a vibration on a trip and I had to limp it home. ( drive slower, not in limp mode). Once I get into my driveway I find I cannot get the shifter into park, or reverse. I put wheel chocks under the wheels and crawled under to find the front driveshaft U-Joint shot. ( ordered a new one. Waiting for it's arrival)
I searched this forum and found info on a number of causes many of which are confusing or refer to parts or places I do not have or cannot find on my ML.
Does anyone have a suggestion as to what may be the issue caused from the vibrating driveshaft, so I'm not spinning my wheels (NP) looking at brake light switches and override covers.
Thank Again.
 

·
Registered
Dallas, Texas
Joined
·
7,715 Posts
Disconnect linkage at transmission. Try to move shifter. Any spills in shifter area?
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,532 Posts
and crawled under to find the front driveshaft U-Joint shot. ( ordered a new one. Waiting for it's arrival)
You have me a bit confused the front shaft is a double ujoint you say ordered a “new one”
not “2 new ones”?

They are also availability various ways sealed or with grease fittings. Part number of what you ordered please.
 

·
Registered
04 ML500, 98 SLK230, 92 500SL
Joined
·
38 Posts
Discussion Starter #5
Nothing was spilled in the shifter area. I got off the highway and arrived at my destination with the vibration. turned off the ignition, car in park. Completed my task. Got back in the car started the engine, put in reverse, backed out of the driveway, back into drive and limped home. Then in my home driveway, after about 12 miles of driving under 40mph, the shifter would not move forward past neutral.
Regarding the U-Joint...I ordered a complete new driveshaft with double u-joint.
 

·
Registered
04 ML500, 98 SLK230, 92 500SL
Joined
·
38 Posts
Discussion Starter #6
Example of a part or place you can not find? =
The shifter override cover.
 

·
Registered
04 ML500, 98 SLK230, 92 500SL
Joined
·
38 Posts
Discussion Starter #7
"They are also availability various ways sealed or with grease fittings. Part number of what you ordered please. "
Dude, the driveshaft part of the problem is solved. I need help with the shifter that will not go past neutral. That is the purpose of my post.
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,532 Posts
The shifter override cover is the small hole bottom left of shifter you stick a pen or similar into in order to move lever for towing when ml will not start. It has a tiny spring load flap

Page 243 of manual on 2003


You already orderered it but for others the drive shaft can be rebuilt by replacing u joints. The ujoints rarely go bad though how many miles on this.
Other drive train issues occur before ujoints
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,532 Posts
Dude, the driveshaft part of the problem is solved. I need help with the shifter that will not go past neutral. That is the purpose of my post.
“I put wheel chocks under the wheels and crawled under to find the front driveshaft U-Joint shot. ( ordered a new one.”.

When you said you ordered one ujoint it sounds like you did not have it solved since there are 2. Good luck to you.i got better ways to spend a Sunday morning.
 

·
Registered
04 ML500, 98 SLK230, 92 500SL
Joined
·
38 Posts
Discussion Starter #13
You already orderered it but for others the drive shaft can be rebuilt by replacing u joints. The ujoints rarely go bad though how many miles on this.
Other drive train issues occur before ujoints
[/QUOTE]
For full disclosure: U Joints cost between $22 and $106 and you need to spend your time removing and installing, then reinstall the driveshaft. OR....order a new driveshaft with a 2yr warranty for $108. Save the time of rebuild and get the warranty. You have free will!
Now ....back to the issue at hand.....
 

·
Registered
04 ML500, 98 SLK230, 92 500SL
Joined
·
38 Posts
Discussion Starter #15
Witek, I tried the pen in the hole. I pushed until I felt intense resistance. Nothing changed. Is there some trick that I am missing? Move the pen forward or back or feel for a "click"...?
More info: the driveshaft is removed. There is no evidence of impact. nothing scaring the tranny or the linkage. No marks that the shaft hit anything. I'm hoping that there is no problem inside the tranny.
Thanks for your help.
 

·
Registered
2002 Mercedes Benz ML320
Joined
·
43 Posts
Thanks in advance for any help from the community.
My ML developed a vibration on a trip and I had to limp it home. ( drive slower, not in limp mode). Once I get into my driveway I find I cannot get the shifter into park, or reverse. I put wheel chocks under the wheels and crawled under to find the front driveshaft U-Joint shot. ( ordered a new one. Waiting for it's arrival)
I searched this forum and found info on a number of causes many of which are confusing or refer to parts or places I do not have or cannot find on my ML.
Does anyone have a suggestion as to what may be the issue caused from the vibrating driveshaft, so I'm not spinning my wheels (NP) looking at brake light switches and override covers.
Thank Again.
Witek, I tried the pen in the hole. I pushed until I felt intense resistance. Nothing changed. Is there some trick that I am missing? Move the pen forward or back or feel for a "click"...?
More info: the driveshaft is removed. There is no evidence of impact. nothing scaring the tranny or the linkage. No marks that the shaft hit anything. I'm hoping that there is no problem inside the tranny.
Thanks for your help.
I suspect that you have a faulty stop lamp switch
 

·
Registered
04 ML500, 98 SLK230, 92 500SL
Joined
·
38 Posts
Discussion Starter #17
The brake lights come on when the pedal is depressed with the key on. Could there be another issue? I was surprised that the key had to be on for the brake lights to work.
 

·
Registered
04 ML500, 98 SLK230, 92 500SL
Joined
·
38 Posts
Discussion Starter #18
I need this truck for my business. If I can get the tranny working right is there any problem driving it without the front drive shaft in? I do not go anywhere that I need the front drive. I just want to be sure I won't screw up something else if I drive it with just rear drive.
 

·
Registered
Dallas, Texas
Joined
·
7,715 Posts
I need this truck for my business. If I can get the tranny working right is there any problem driving it without the front drive shaft in? I do not go anywhere that I need the front drive. I just want to be sure I won't screw up something else if I drive it with just rear drive.
ML has three open diffs. It will not move one inch with any drive train components disconnected.
 

·
Registered
2002 Mercedes Benz ML320
Joined
·
43 Posts
The brake lights come on when the pedal is depressed with the key on. Could there be another issue? I was surprised that the key had to be on for the brake lights to work.
It’s not just the brake lights that the stop lamp switch interfaces with. It is also connects with the prindle switch
which affects the selection of gears in the transmission. In my experience I have had to replace both switches
 
1 - 20 of 37 Posts
Top