Mercedes-Benz Forum banner

1 - 20 of 21 Posts

·
Registered
2003 SL500 , , 2012 E350 4matic wagon
Joined
·
61 Posts
Discussion Starter #1
Does anybody know how to reset the service interval indicator? The instructions in the manual don't seem to be correct - key position 2 , bring up service page, hold reset. Tried another method from other post close doors, key position 2 , bring up fss screen return key to position 0 , while pressing reset return key to position 2 until beep. Any help would be appreciated Thanks
 

·
Registered
Joined
·
85 Posts
Just had to figure this out myself this week. You have to do exactly this. If you make a mistake you have to start over and take the key out etc

Get in car and turn key to position 1

IMMEDIATELY hit the rest button three times (You have to do this within 3 seconds)

You should the the multi function display show voltage now. Scroll down using the button on the steering wheel and get to the page showing oil meansurement (Can't recall exactly what it says but it will be obvious this is a service menu

Turn key to position 2 (You must do this at this time)

You should now be able to scroll to where it will ask for oil type (I beleie i only had one choice like Oil 1.0 or something to that effect.

Work your way thru that menu and it will ask you to hold reset for 3 seconds on the multi function display. If you do that it will reset and you will see your next service interval. For me at said sevice B in 13000 miles

The main thing is getting the voltage to come up by turning to position 1 and hitting reset 3 times in less than 3 seconds. Once you are there you will be able to intuitively work your way thru the menus. Just remember to turn it to position 2 only when you get to the service menu screen.

Good luck - Dealers try to screw us and say you need to take it to them to rest it but that is BS, i was able to reset it myself on my 2005 SL500 jsut the other day
 

·
Registered
'04 SL 500; '05 SLK 350
Joined
·
166 Posts
Here's what the manual has to say - Mercedes gives you a detailed description how to reset the service indicator.
Service indicator reset.jpg
 

·
Registered
00 Audi TT & 00 E320 4M
Joined
·
1,547 Posts
Here's what the manual has to say - Mercedes gives you a detailled description how to reset the service indicator.
View attachment 235034
Thank you for that

all that "hit it 3 times" then look for "voltage" display etc...
was driving me bonkers !!!:surrender::goojob:
 

·
Registered
Joined
·
72 Posts
On my B class I did that 'hit reset 3 times' and it came up with a list to select what service you've done.

But i tried this on the SL and it just didn't work!

I followed the reset service indicator as in the manual and its now gone back to service A...
Any ideas?

How do you actually tell it that you've done a full service?
 

·
Registered
Joined
·
72 Posts
I can't get the voltage to show up for the life of me...
Done key to position one then push button three times immediately...no luck, any ideas? :S
 

·
Registered
2007 SL550
Joined
·
33 Posts
Service A required

Hi,
I have a 2007 SL550. Manufactured April of 2007. My dash says service a required. I cannot get this damn message off. I have tried the turn the ignition to position 1, press reset button for 3 seconds, etc. All that does is reset my trip odometer. I have one of those star diagnosis machines, but alas it came without any instructions and I cannot figure it out.
Can anyone tell me how to turn off this message?
Thanks, Greg
 

·
Registered
2007 SL550
Joined
·
33 Posts
In DAS (Star Diagnosis) from the main menu choose control units, then information and communication (or similar), then instrument cluster, and from there ASSYST. You'll find a number of settings in that menu which include resetting and adjusting parameters for service notifications.

Most or all SDS systems include "DAS SIM" which allows you to navigate all of the software menus as if the PC were connected to a car. This is how I learned to use DAS.
Hi Rod,
I really appreciate the help. Unfortunately for me, I do not have the ASSYST option. My "instrument cluster with maintenance interval display" screen has things like "control unit version", "fault codes", "events" etc., no assyst.
I actually bought the star diagnosis to turn on the fader control for my rear speakers because I had been assured it could be done with xentry developer. When push came to shove, same thing, the version I have has different menus than the instructions I was given. :(
Greg
 

·
Registered
2003 SL500, 2000 S500
Joined
·
364 Posts
I screwed-up. My earlier post incorrectly stated the path, and I deleted the post. Here is the correct path to the settings for service interval:

Control units > Information and communication > ICM > Control unit adaptations > ASSYST settings​

Hi Rod,
I really appreciate the help. Unfortunately for me, I do not have the ASSYST option. My "instrument cluster with maintenance interval display" screen has things like "control unit version", "fault codes", "events" etc., no assyst.
I actually bought the star diagnosis to turn on the fader control...
I remembered seeing a fader setting a few weeks ago, and it is here:
Control units > Information and communication > D2B-Comand or Audio > Development data > Control unit adaptations (Variant coding) > D2B Varientkodierung > Fader​
But I have a hunch this will do nothing with the hardware in a U.S. car.

I personally see no value in having a fader in an SL -- it just wouldn't make any sense. In a typical setup a fader takes a full channel of audio and divides it between front and rear speakers. But in this case the rear speakers are simply two small midrange drivers for surround sound (see the diagram Diablo posted here). Those two speakers could not properly reproduce a full channel of audio. Further, they are wired in series to a single channel of the Bose amplifier.
 

·
Registered
2007 SL550
Joined
·
33 Posts
That path worked for me, thanks. The fader one however did not. I can get to the variant coding, but thats when I do not have the fader option. I do not know how much difference it would make, but since no sound comes out of those speakers, I would like to see. I live in the middle of hicksville, nowhere, and this car is just too much for most people. The dealer knows nothing about them, audio guys won't touch it. Oh well, I still love the car.
Greg
 

·
Registered
2007 SL550
Joined
·
22 Posts
I really tried to search this - Reset Service B indicator - Help!

Being a veteran of this forum, I tried extensively to search for how to reset the service B notice before asking. The problem is the procedure seems to work for resetting it BEFORE you hit the date. Now that mine says "you have exceeded the service B by X days", the "key to position 2, hold the reset button for 3-10 seconds" does nothing.

I have my car regularly serviced and do a lot of it myself (like air filters, cabin filters, etc.). I just forget to get this reset from the oil change place (assuming they know how).

Thanks guys as always!

Mod Note - theintelligent1: Thread merged....
 

·
Registered
Joined
·
1 Posts
Just had to figure this out myself this week. You have to do exactly this. If you make a mistake you have to start over and take the key out etc

Get in car and turn key to position 1

IMMEDIATELY hit the rest button three times (You have to do this within 3 seconds)

You should the the multi function display show voltage now. Scroll down using the button on the steering wheel and get to the page showing oil meansurement (Can't recall exactly what it says but it will be obvious this is a service menu

Turn key to position 2 (You must do this at this time)

You should now be able to scroll to where it will ask for oil type (I beleie i only had one choice like Oil 1.0 or something to that effect.

Work your way thru that menu and it will ask you to hold reset for 3 seconds on the multi function display. If you do that it will reset and you will see your next service interval. For me at said sevice B in 13000 miles

The main thing is getting the voltage to come up by turning to position 1 and hitting reset 3 times in less than 3 seconds. Once you are there you will be able to intuitively work your way thru the menus. Just remember to turn it to position 2 only when you get to the service menu screen.

Good luck - Dealers try to screw us and say you need to take it to them to rest it but that is BS, i was able to reset it myself on my 2005 SL500 jsut the other day
This procedure worked on my 2006 SL500. Thank you!
 

·
Registered
2003 Mercedes SL500
Joined
·
40 Posts
Resetting Oil Gauge

I changed the oil and filter on my 2003 SL500 today. Is there any way to reset the oil gauge or do I have to take it to the dealership to have them reset it. Thanks for your responses in advance.

Mod Note: theintelligent1: Please do a search before starting a new thread. Refer to the sticky at the top of the forum
 

·
Registered
2001 E430 4Matic Sedan; 2004 E500 4Matic Wagon; 2006 SL500
Joined
·
5 Posts
Thanks Robert. Worked for me 3-08-2016

I did this and it worked. I don't think I did the key to position 2. I think I hit the reset at that point but, as you said, you kind of work your way from the oil type screen to the service indicator reset and then press the button. It comes back and says "confirmed".
 
1 - 20 of 21 Posts
Top