Mercedes-Benz Forum banner

1 - 20 of 24 Posts

·
Registered
96 G300DT
Joined
·
2,011 Posts
Discussion Starter #1 (Edited)
Let me start off with: I know how to reset the FSS miles-til-service. I've been driving vehicles with this instrument cluster for ~350K miles, doing all my own maintenance. This problem is different: not miles, but days.

After resetting the miles to 10000, I still get a "Service due in 0 days" warning. This is followed up the next day by a "Service due NOW" warning, which repeats every time the engine is started. Of course, I can repeat the FSS clear routine, which sets miles to 10000 again and also sets the days to 0. That is what I did to shoot the picture included below.

How do I set the day counter to something sensible?!?
 

Attachments

·
W210 Moderator
99 E320
Joined
·
5,089 Posts
my US 1999 E320, the past month, has been counting down the days. it's
probably at D-day now so i should get off the keyboard soon..... :) don't
want it to get angry and start spitting out codes.
 

·
Registered
96 G300DT
Joined
·
2,011 Posts
Discussion Starter #4
Is that on 96 or 98 model?
I was under the impression that FSS in USA models did not get day limit till MY 2000 or so.
It is in my 1996 G300, basically a 1998 E300 with a G-wagen body. I have a 1998 E300 too. The instrument cluster, engine, transmission, controls, all the computers, etc are the same.

How does one set the days on the later models?
 

·
Registered
E320/E250 Bluetec Ford F350 6.7l
Joined
·
36,492 Posts
In my 1998 E300 the FSS resetting is in manual.
Don't think I have time set for this MY and I did not have time for sure in 1999 ML320.
Per my understanding the time and mileage should reset at the same time, so it is surprise that you reset the miles, but not the time.
 

·
Registered
96 G300DT
Joined
·
2,011 Posts
Discussion Starter #6
In my 1998 E300 the FSS resetting is in manual.
Don't think I have time set for this MY and I did not have time for sure in 1999 ML320.
Per my understanding the time and mileage should reset at the same time, so it is surprise that you reset the miles, but not the time.
Well it does reset both the time and miles. The miles get reset to 10000, unfortunately the time get set to 0 days. That is what I am trying to fix.
 

·
Premium Member
2001 E320 - Brilliant Silver/Ash: 107,000+
Joined
·
17,193 Posts
This is odd. I thought like Kajtek1 stated that the days until service due and miles reset at the same time. So if anything, the days should reset to (?) 730 days or 2 years.
 

·
Registered
96 G300DT
Joined
·
2,011 Posts
Discussion Starter #8
This is odd. I thought like Kajtek1 stated that the days until service due and miles reset at the same time. So if anything, the days should reset to (?) 730 days or 2 years.
The days change from "now" to "0 days" each time I reset the FSS. Not all that helpful in the grand scheme of things.
 

·
Premium Member
2001 E320 - Brilliant Silver/Ash: 107,000+
Joined
·
17,193 Posts
But when the time goes by, is it counting to negative days? Since this is early FSS, maybe you have display but no counter?
Good question. Right now I have exceeded the time limit since service A and every day it tells me I am past due by XX days; each day it increases by 1 day. I think it switched over from miles until service to days until service at 30 days.
 

·
Registered
1999 E300td, 154,000 miles
Joined
·
7 Posts
My brothers 1999 e320, just yesterday popped up service in 30 days, and we were both wondering what was going on. As with Alan, I'm familiar with how to reset the FSS clock, but have never encountered this, I have a 1999 e300 & have reset both of them many times. I'll be interested to hear of a solution.
 

·
Registered
Joined
·
37 Posts
fss

1999 e300 cannot reset the warning due for maintenance for more 10kmiles.
every time turn the ignition stays on for few minutes and it will clear.
 

·
Registered
1999 E55t AMG
Joined
·
372 Posts
I have the exact same problem, only on a 2001 ml320. Ever find a solution?
I have the exact same issue on my '99 E55t, euro spec car imported from Japan, no OBD2 port, just the underhood 38 pin connection. I haven't been able to find a solution yet either.
 

·
Registered
96 G300DT
Joined
·
2,011 Posts
Discussion Starter #18
I have an 1999 E300TD that has the same issue. Any solution? Or, does one have to go to the dealer for this?
Well, I have a friend with the dealer tools, and he was unsuccessful at resetting it. That may have been pilot error though.
If you do go to the dealer, see if you can get an agreement that you won't pay unless they actually fix it. Do let us know how it turns out.
 

·
Registered
1999 E55t AMG
Joined
·
372 Posts
Well, I have a friend with the dealer tools, and he was unsuccessful at resetting it. That may have been pilot error though.
If you do go to the dealer, see if you can get an agreement that you won't pay unless they actually fix it. Do let us know how it turns out.
When you say "dealer tools", do you mean STAR C3/4 DAS Xentry setup? Or what?
 
1 - 20 of 24 Posts
Top