Mercedes-Benz Forum banner

1 - 20 of 38 Posts

·
Registered
1998 W140 S420
Joined
·
271 Posts
Discussion Starter #1
Hi to all, i recently started experiencing interesting stuff, a month ago when we where working on the car we saw that the trunk stopped self closing, then 3 weeks ago the driver door stopped self-closing, then 1 week ago, the rear left door stopped self closing, the only doors that work are on the right side, anyone has an idea of what is going on? I mean i know that there are vacuum pumps, but im not sure if mine are bad or if its the lines that are bad, im not on a subject to hurry and would appreciate some help
 

·
Registered
1997 S500V, 1999 S500 grand edition, 2006 s65 amg
Joined
·
7,356 Posts
try resetting the vacuum pump. its a green fuse in the trunk remove it for 5 seconds and it will reset.
 

·
Registered
1997 S500V, 1999 S500 grand edition, 2006 s65 amg
Joined
·
7,356 Posts
on my car fuze #8 or #9
i cant remember the fuse number but i know that resetting fixes for another 2-3 cycles if its damage. on mine the pump itself is getting weak because now even after the fuse removal it doesn't even work it needs help :(
 

·
Registered
W140 S320 1998
Joined
·
323 Posts
Hi Guys,
I am pretty sure its number 9. Have you guys watched this video:


It sorted out all my close assist issues and I just did blow by blow what the guy is talking about and doing. Be carefeul with that diaghram assembly as its tough to open and you may get frustrated and break it!!! I think that pump has issues from the factory.....
Hope this helps!!!
regards
rikana
 

·
Registered
1997 S500V, 1999 S500 grand edition, 2006 s65 amg
Joined
·
7,356 Posts
On mine 2 of the actual valves are bad so for me its pointless lol. And yes every mercedes with close assist messes up because people slam the door and trunk. My former w220 had the issue with trunk and driver door. And on the w221 i have seen how fast they fail sadly it was 09 s550 that failed only in 3 years. I personally perfer a car that doesnt have close assist. Well that was my experience and opinion
 

·
Registered
W140 S320 1998
Joined
·
323 Posts
Okay....I think closing assist is a great toy and a real wow factor when it comes to showing off your w140. Just wondering if you done hae it is there any other way of aligning the trunk?? I alo understand the newer versions have som kind of motors in the door.....am thinking a possible mod......anyone here thinks we can swap out the systems??
 

·
Registered
1995 mercedes S420
Joined
·
228 Posts
make sure the part # mach your pump, or it might not work . it happened to me . 1 number was diff and didnt work
 

·
Registered
1998 W140 S420
Joined
·
271 Posts
Discussion Starter #10
try resetting the vacuum pump. its a green fuse in the trunk remove it for 5 seconds and it will reset.
It worked!, Thanks, however it seemed to suck in slowly like it had low pressure, i did try it 4 times on my door and it sucked it in 4 times,but, u think my pump is going bad as well?
 

·
Registered
1998 W140 S420
Joined
·
271 Posts
Discussion Starter #11
make sure the part # mach your pump, or it might not work . it happened to me . 1 number was diff and didnt work
will consider it, thanks
 

·
Registered
1998 W140 S420
Joined
·
271 Posts
Discussion Starter #12

·
Registered
1998 W140 S420
Joined
·
271 Posts
Discussion Starter #13
Hi Guys,
I am pretty sure its number 9. Have you guys watched this video:

Mercedes door close assist pump repair. W140 S-class - YouTube

It sorted out all my close assist issues and I just did blow by blow what the guy is talking about and doing. Be carefeul with that diaghram assembly as its tough to open and you may get frustrated and break it!!! I think that pump has issues from the factory.....
Hope this helps!!!
regards
rikana
Thanks for the vid, will consider if anything else comes up
 

·
Registered
W140 S320 1998
Joined
·
323 Posts
Yeah....I suggest you try the fix then if it doesnt work you will know its has other issues......
 

·
Moderator
93 SL500, 95 SL320, 96 S320, 98 S500, 2002 E320 4Matic Wagon & A little 91 5.0 FORD Mustang
Joined
·
8,064 Posts
I had the same thing happen to me!

I dissembled the pump mechanism, and cleaned out the internal vane-fins & cavity with denatured alcohol(the alcohol you get at the home center). I used several cotton swabs to clean-up the dust, and cleaned until the swabs came out clean. Re-assemble the pump, but tighten the screws equally in a star pattern, and do not over tighten!

Next, I get some 400 grit sand paper, or use a fine nail-sand paper from the beauty supply, and clean the copper mating contacts of relay responsible to power the motor.

It fixed my problem, and I did it watching tv. It took about 1hr .

No need to spend big money on this.

Martin
 

·
Registered
1995 S 420, 2012 GLK 350 and 1997 Audi Cabrio; Previously 1982 280CE, 1974 450SL, 1974 911S Targa
Joined
·
456 Posts
make sure the part # mach your pump, or it might not work . it happened to me . 1 number was diff and didnt work
Is there a difference between the Hella and Bosch supplied vacuum pumps???
 

·
Registered
1997 S500V, 1999 S500 grand edition, 2006 s65 amg
Joined
·
7,356 Posts
I had the same thing happen to me!

I dissembled the pump mechanism, and cleaned out the internal vane-fins & cavity with denatured alcohol(the alcohol you get at the home center). I used several cotton swabs to clean-up the dust, and cleaned until the swabs came out clean. Re-assemble the pump, but tighten the screws equally in a star pattern, and do not over tighten!

Next, I get some 400 grit sand paper, or use a fine nail-sand paper from the beauty supply, and clean the copper mating contacts of relay responsible to power the motor.

It fixed my problem, and I did it watching tv. It took about 1hr .

No need to spend big money on this.

Martin
so lets say if I send you my pump with Scarface Blu Ray and sand paper, and rubbing alcohol and cotton swabs and a bottle of hennesy you can repair :) on mine the hoses on the side are ripped too so i am guessing my pump was abused lol and i doubt it can be rebuilt by any company.
 

·
Registered
1995 mercedes S420
Joined
·
228 Posts
so lets say if I send you my pump with Scarface Blu Ray and sand paper, and rubbing alcohol and cotton swabs and a bottle of hennesy you can repair :) on mine the hoses on the side are ripped too so i am guessing my pump was abused lol and i doubt it can be rebuilt by any company.
lol, no comment
 
1 - 20 of 38 Posts
Top