Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
2005 ML350 Special Edition
Joined
·
12 Posts
Discussion Starter #1
Hey guys


Before I posted I searched the forum and found a lot of interior light problems but nothing like mine....

What happens is that when I get in the car, I start the car up and while its starting up the lights go out and just the car starts up a second later the two overhead lights (reading lights) turn on and I have to turn them off. Would anyone have any idea what might be causing this???

Thanks in advance
 

·
Registered
2005 ML350 Special Edition
Joined
·
12 Posts
Discussion Starter #3
Yes...I will get in the car shut the door...they will slowly start to dim and then go off....once I start the car the lights pop back on and I have to turn them off myself. I dont know if they turn off when I start to drive for a bit but I have driving like 20 meters and they are still on
 

·
Super Moderator
99 ML430, 00 ML320, 05 E500 4matic Wagon
Joined
·
22,135 Posts
They are on a timer. Give it 20-30 seconds once the engine is running and all doors are closed.
 

·
Registered
2005 ML350 Special Edition
Joined
·
12 Posts
Discussion Starter #5
Actually last night on the way home I tried leaving it on and see what happens and it actually was on for over a km so then I turned it off myself...
 

·
Premium Member
02 ML320 06 ML500
Joined
·
17,104 Posts
Try opening the passenger door and starting the truck and see if the lights fade out as they should.
 

·
Registered
ML320,C230, F250, Bayliner, Mountain Bike, Fleetwood Motorhome etc...
Joined
·
1,836 Posts
I hated that feature so I installed a toggle switch and put it where the garage door opener goes. You have to remove the whole overhead light assembly then wire in a toggle switch to both lights. Problem solved...
 
1 - 7 of 7 Posts
Top