Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
1990 300e
Joined
·
7 Posts
Discussion Starter #1 (Edited)



First off I would like to say hello to the MB forums. This is my family's car and am not familiar with MBs but I really want to get this thing running good again because its a pleasure to drive.

So we have a 1990 300e in the family with just over 100k on it and its been having this weird issue for about two years now. It started as a cold start issue only in cold weather (30* or lower), it would just crank and crank and eventually you could get it started, it probably took 10 min or so of cranking for a few seconds and repeating. As soon as the car was up to temp it would run without any issue. However this winter it has gotten to the point were the car has no power when its up to temp.

Now the car will immediately turn over and run for a second then stall, this process has to be repeated 6-8 times before it finally will idle. Even when she is up to temp if you give it enough gas to get out in traffic it wants to die and if poked hard enough will. Hell, it even has a hard time just idling.

This video was taken maybe two months ago when the car still ran O.K. when it was up to temp.

This is a video I took two weeks ago and you can see how it has gotten a lot worse. When the RPM's are around 500 thats the car in D and when their around 900RMP's thats P. You can see when Im on the throttle because the economy gauge gets pegged and the RPM's do nothing then stumble and rise.

I have replaced the OVP with no difference, and it runs even worse with it removed. Ive read the coolant temp sensor could be the issue and checked it by crossing the pins and it seems to be within the proper range when cold. Ive also read it could be the Idle Air Control Valve and will have to check that next time Im down at the parents place. Other than that I assumed it could be the cold start valve but now that its just running badly even when warm I think thats ruled out. Also It has not spit out one CEL. New cap, rotor, plugs, wires.

Any help would be most appreciated.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Welcome to Benzworld
 
1 - 2 of 2 Posts
Top