Mercedes-Benz Forum banner
1 - 4 of 4 Posts

·
Registered
1995 E320
Joined
·
3 Posts
Discussion Starter · #1 ·
Greetings Mercedes Gurus,

The patient is a 1995 E320. Under the car, beside the transmission oil pan, on the driver's side there are two rubber hoses. One is significantly larger than the other in diameter. This one is sagging down, almost as far as the bottom of the transmission oil pan. At its trough, the hose has clearly swollen in size, but does not appear to be leaking or cracked.

I've taken a look under other Mercedes, and this does not seem to be happening on theirs. I am not sure what the part is. Tracing the hose back towards the front towards the engine, it appears to be enclosing a white or gray or silver, almost metallic tube. Any ideas on what this part is and what is causing this? There is an attachment on this hose further back towards the rear, securing it to the pan.

No fluid is leaking out of the house. It just looks strange, not quite right. I don't have a picture of it, but if you have an E class owner's bible, you can see it on pages 91 and 93. Unfortunately, they don't indicate what it is.

Any insight would be appreciated. Thanks in advance.
 

·
Registered
'07 GL320CDI
Joined
·
5,116 Posts
It's the speedo cable, which runs inside a protective hose.

Just tuck it up out of the way, possibly by pulling from inside car.
 

·
Registered
Joined
·
38 Posts
Mine was held up with a zip strip. I had to cut it loose to pull the speedometer pannel out. I thought it might catch on road trash.
 

·
Registered
1995 E320
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks for the tip, gents.

Speaking of speedometers, I have noticed that the needle is bouncing around a little bit until I get up to around 30 mph or so. Not sure if that is related to the sagging cable, or just coincidental.
 
1 - 4 of 4 Posts
Top