Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi
New s500 2000 220 owner, I have a problem, has anyone got suggestions.
Driving home ,parked the car and as I went up kerb with front left wheel
suddenly something broke, loud grinding noise from lhs.
Suspension looks fine, nothing obviously broken. Noise is louder in Park and Neutral, gets worse as you rev engine. Noise gets less in drive and reverse,
still able to move stick fine, noise there at idle. Not sure if going up kerb had anything to do with problem could be pure coincidence.

Could it be gearbox, is this car just rear wheel drive? Doesnot say 4matic on boot.
It must be engine linked or would not get worse when reving engine Correct?
Any ideas, hoping its not catstrophic and expensive
Car done 158k but MB serviced, few electrical issues but overall excellent car so far

Torgue converter? ABS pumps or is it gearbox related, mechanic looking it over tomorrow

Thanks

Pete
 

·
Registered
Joined
·
6 Posts
my abs pump made a strange noise when it was bad, it comes from under the hood left side. noise stops when driving, but when reaching to a corner and the rpm falls it comes back again, even if the car is rolling. after pressing the gas pedal it goes away.
not sure if this is your problem, but mine resolved after replacing abc pump.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
well things have moved on gears all over the place, grinding noise in all positions

i think gbox fuked

looking for a replacement anyone any ideas
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
what should i look out for when trying to replace gearbox / torque converter
can i put a 2003 s class gearbox in it only 38k he says

mine is semi auto what are my options?
any help greatly appreciated

now crying into beer its my sodding birthday today as well thank you god thank you so very much
 
1 - 5 of 5 Posts
Top