Mercedes-Benz Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
the problem i am having is my car was running fine, and then all the sudden it just cuts off. If I try to start it right back up it will turn over but will cut right back off. If I let it sit for a while it will turn back on a run for a few, but then cut back off. I have a brand new battery in. I was told it could be a number of things, but I was hoping someone could help me get started to figure out what it could be. The car is a 93 s500.
 

·
Registered
Joined
·
87 Posts
r u getting a check engine light?
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
I could be wrong, but I read that the ASR light is a sensor on the brakes, so I dont see how that would make the car cut off. And plus the ASR had already been coming on for about 3 months and i didnt have this problem.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
Okay, I just started it, and it started just fine, ran for about an hour, and then cut off. It seems like something is getting hot.
 

·
Registered
Joined
·
341 Posts
I made the mistake of going to the dealership and they replaced the electronic throttle actuator (or something like that) and told me the car was fixed - cost $2100. I got home and the car had the same symptoms. After I complained they took another look and replaced the fuel pressure regulator - cost $149. That fixed the car. I accused the service manager of shoddy troubleshooting and was told that both parts were in need of replacing. I refuse to go back except for parts.
 

·
Registered
Joined
·
341 Posts
My car was difficult to start when the engine was warm. I would need to crank the ignition for 10-15 seconds. If I let the car sit overnight it would start without difficulty. Occasionally when the engine was warm, it would start, but it lacked power. I would have to keep my foot on the gas to keep the car from stalling. Also I would get the ASR light at these times. Shutting the car off and restarting the engine would provide a temporary fix and the car would operate normally. I changed the battery and replaced the fuel filter, which did not fix the problem. The fuel pressure regulator was at fault. I never experienced the car shutting off unless I had a poor start as mentioned above. I only mention this repair because some of your symptoms and repairs coincide with mine.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #15
My car was difficult to start when the engine was warm. I would need to crank the ignition for 10-15 seconds. If I let the car sit overnight it would start without difficulty. Occasionally when the engine was warm, it would start, but it lacked power. I would have to keep my foot on the gas to keep the car from stalling. Also I would get the ASR light at these times. Shutting the car off and restarting the engine would provide a temporary fix and the car would operate normally. I changed the battery and replaced the fuel filter, which did not fix the problem. The fuel pressure regulator was at fault. I never experienced the car shutting off unless I had a poor start as mentioned above. I only mention this repair because some of your symptoms and repairs coincide with mine.
thanks for the help, i will see if this is the problem.
 
1 - 15 of 15 Posts
Top