Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
S430
Joined
·
7 Posts
Discussion Starter #1
Purchased a 2000 S430 back in January 2003 and for the first 8 or 9 months it ran like a dream, still does to a great extent, the problem I'm having is that for the last month or two I have begun to hear a "rumbling creaking" sound coming from the front left wheel area. When I would get out of the car instead of hearing nothing or what I can only describe as compressed air which I assume is the air-matic suspesnsion readjusting itself (God don't you just love Mercedes engineering) I now hear a metallic racheting sound for lack of other term. I took it to the closest Mercedes Dealership I could find and they deduced that it was a lower left rocker arm that needs replaced that the bushing is rubbing up against it. So since it's StarMark certified the dealer said that the warranty should cover it. When I got the car back almost immediately the noises started up again this time much worse and to the point where I got several messages across my dashboard referencing Air-Matic suspension, BAS Assist and ABS all needing attention. I took it back to the dealer immediately and found out that they replaced the WRONG rocker arm so this time they replaced the left rocker arm. I got it back today and after a couple of hours - you guessed it - the sounds are back. I think it's the air-matic suspension - my car has 60,000 miles on it anyone else had similar experinces. I'm trying a new dealer this week. It's a shame because everything else on the car is great and runs fine, except my NAV CD player but that's another story ;-)
 

·
Registered
SLK 320
Joined
·
33 Posts
Have similar issue on driver side . same noise your refer too..

We have similar issue on driver side . same noise your refer too.. planning on taking the car in soon. We did receive a message on dash - Break Pad Wear - See Dealership. At the same time; the clock on the dash / command won't link-up with the satellite and its off by more then 2 1/2 hours. Plus, now our signal for phone and radio cycles every 15 seconds or so. Glad we got the extended warranty .. we shall see what they discover. Already had new suspension system put in car when it was 3 months old (car was 1/2 off the ground and could not be driven.
 
1 - 2 of 2 Posts
Top