Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello Folks,

All of a sudden when i parked my car today and shut it off. I heard the airmatic system continuously running. Usually after about a few seconds it stops running but this time around it just kept running and i figured something was wrong so i sat by the car and waited. So after about 7 minutes i suddenly started hearing a loud banging noise coming from the front passenger side. That loud banging came on and off for about another 3 minutes and then stopped. After it stopped i started the car and pressed the air rising button and the vehicle worked fine with no problem. Then i waited for say 5 hours and went back to the car, the car level was at a normal level. The funny thing with all this is that i replaced the airmatic pump, valve, the struts repair thing (both sides as i was told) sometime in January of 2010 and it is now November. This whole repair cost me $2200. I dont know what the problem could be and i hope for the sake of the shop that i don't have the same problems all over again. The car level is fine and is not dropping to the ground like i experienced in January. ANY IDEA WHAT THIS MIGHT BE? The loud banging noise was so loud that you will think you are at a construction site. Thanks for the response.
 

·
Registered
Joined
·
2 Posts
same problem

I had the exact same problem for the first time yesterday morning. I wonder whether it may have been related to using the heater for the first time in a long time. It was really cold that morning. I used the heater (climate control) going to the gym. When I came out of the gym, the car was making the loud banging side from the right passenger side. The noise did sound like air pressure or a valve was trying to get released or get stabilized. The banging went away when I started the engine. The car ran OK. The banging sound came back when I turned off the engine at home. It did stop after several minutes. So far, it hasn't come back but I'm keeping my fingers crossed. If the banging comes back, I think that I will have to get the car looked at.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I think its the airmatic compressor. If you check the fuse on the right passenger side (40A) when you open the hood i bet its blown. It think it originated from a bad relay and it that loud banging noise was because the pump blew. It was really cold when mine happened and i initially thought it was the cold but later remembered that this particular doesnt really do stuff like that unless something is really wrong. Funny thing is never get a warning before something breaks down on the car. You never hear any funny noises until the minute it is about to breakdown.
 

·
Registered
Joined
·
2 Posts
Thanks for the update. I will check out the fuse. I agree with you about any lack of a warning sign until it's broken.
 
1 - 4 of 4 Posts
Top