Mercedes-Benz Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
36,559 Posts
Discussion Starter · #1 ·
I brought in our '94 S600 to the shop because of rough idle and stuttering engine, the dealer said that the engine and body harness must be replaced (3K!!) as the harness has cracked and the wires inside are exposed and probably could lead to futher engine problems. Any thoughts on this or similar experiences ? Is it really necessary to replace the harness ?<br>
<br>
 

· Registered
Joined
·
36,559 Posts
Discussion Starter · #2 ·
This is true! I have a 92 400se and it does the same thing. Two weeks ago I took my car to the Mercedes dealership to get it's 105,000 mile service. Within the last two weeks the idol has been a little ruff and the car tends to stutters slightly after i accelerate. Up until now this condition is inconsistant but when it does happen it's very noticeable. To get two different opinions about what the hell is going on with my car, i brought it to two different Mercedes dealerships and they have both told me the same thing. Th harness containing my wires, has dry rotted and cracked and the engine mounts need to be replaced. I have spoken to various technicians and S-Class owners and they have all confirmed this as being normal. To date, My S-class has 105,000. mi on it.
 

· Registered
Joined
·
36,559 Posts
Discussion Starter · #4 ·
Just had this problem. Was quoted $700 for diagnosis, $3K for harness, and 2.3K for labor!! After many calls, there is a not well known simple fix. MB sells a 'splice' to cross the wires in the manifold area for $165. It took tons of calls to various dealers and to find out about this-the harness was already on order. I'll update and should have the part number soon.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top