Mercedes-Benz Forum banner
1 - 12 of 12 Posts

·
Registered
1987 420SEL
Joined
·
1,133 Posts
Discussion Starter · #1 ·
Does anyone have the part number for the rubber hose that sits under the intake manifold and connects the two runners that span all the injector holders?

I also need the part number of the hose that comes off this ^ hose and connects directly to the cold start injector block.

Any help would be appreciated; the dealer's EPC represents diagrams that look less and less like my car every day...

Thanks in advance

-Ryan
 

·
Registered
1995 E320 (totalled) 91 420SEL W126 (retired) 2002 S500 W220(retired); 2008 C300 Sport W204
Joined
·
662 Posts

·
Registered
1987 420SEL
Joined
·
1,133 Posts
Discussion Starter · #3 ·
Thanks for the information.

I looked through the diagram posted, and it essentially defines what the dealership has on thier computer; there's these two odd-looking Y-pipe things that have nothing to do with my car, and no cross-pipe or cold-start feed pipe. Thanks though; this is truly a PITA.
 

·
Registered
w126
Joined
·
1,535 Posts
The hose in the EPC(116 090 08 82) is both hoses. It's possible they aren't sold seperately.
I don't think the connectors are included.

The ribbed piece that connects to the cold start injector housing: 116 094 27 82
The crossover piece: 116 094 24 82
 

·
Registered
1987 420SEL
Joined
·
1,133 Posts
Discussion Starter · #5 ·
THANK YOU!

I'm not too concerned about the connectors; worst case scenario, short lengths of whatever sized metal pipe can be squeezed into them for the time being.

I'm hoping to eventually do away with every rubber hose related to this system, but until that happens, this will work.

Thank you for all replies.
 

·
CH4S Admin , Outstanding Contributor
1985 500SEC, 1991 190E 2.6.
Joined
·
45,156 Posts
The 'welcome to the forum' sticky has the link to a Russian MB site with exploded parts diagram
 

·
Registered
1990 560 SEC(gone but not forgoten) 1988 560SL 1998 E320 4matic wagon
Joined
·
258 Posts
I just got all the hoses at autohaus they had pretty good schematics and could click on the part# to add to the cart. I odrered all the air hoses and the connectors it was under $100
I just hope these are the rough idle problem. But I got a real bad feeling its the rubbers under the intake.
 

·
Registered
'82 Euro 500SEL, '85 Euro 500SEC AMG WB Cabriolet,'86 Euro 500SEC RUF
Joined
·
9,498 Posts
I just did the very same for my 560SEL. Did the job yesterday and with Second day UPS it was under $100.00 with all the air lines and connectors.
While you are doing that I would replace ALL the plastic plugs, air tubes(2, one each side),the main tube and the under plenum tube.(MB sells the main tube and under tube as one assy now(I recommend using MB parts here, I didn't like the parts I received, but used them for the short run(I didn't like the fitment of the connector between the main air tube and the under plenum tube at their juncture. Didn't seem tight enough to me.)
Autohauz uses Febi and Truckline rubber bits.
I'll redo this at a laer date with MB parts.
 

·
Registered
1990 560 SEC(gone but not forgoten) 1988 560SL 1998 E320 4matic wagon
Joined
·
258 Posts
I did order all the nylon connectors. They were cheap and I didn't want to get stuck in the middle of the job with a bad one. They just looked like the kind of deal when you pry the old ones out they go flying then you spend the next 3 hours on you hands and knees looking for it.
plus my hoses are rock hard. I thought they were hard plastic until the new ones came.
 

·
Registered
1987 420SEL
Joined
·
1,133 Posts
Discussion Starter · #11 ·
All is well, I got it all together, and I found the hose on an after-market website.

I went so far as to put hose clamps over all the connections, even the ones to the nylon barb fittings.

Let's see THIS leak.
 

·
Registered
1990 560 SEC(gone but not forgoten) 1988 560SL 1998 E320 4matic wagon
Joined
·
258 Posts
I was thinking of using wire ties on mine. I have some special ones that are used on outboard motor hoses.
 
1 - 12 of 12 Posts
Top