Mercedes-Benz Forum banner
1 - 4 of 4 Posts

·
Registered
1995 E320 Coupe
Joined
·
110 Posts
Discussion Starter · #1 ·
I have noticed on my '94 C280 that at irregular intervals the rpm will drop from 650 to 500 when in D, and from 800 to 600 when in park. When this happens the car shudders as it might turn off, but it doesn't. Also the lights dim when this is happening (headlights, dashboard lights, overhead lights). The engine harness has been replaced and seems in good condition, so I am not leaning toward that being the problem. Anybody has any idea?
Thanks in advance
Raxhi
 

·
Registered
1998 c230 170K
Joined
·
1,415 Posts
Any headway on the problem? Was wondering when it happens in drive does it occur when you depress the brake? If its an issue during start-up the air pump runs for a bit and can cause the gasp-burp you describe. Has the system been checked for stored codes?
The egr pintle may momentarily hang and catch itself sometimes but not enough to throw a code. I know mine is a bit squeeky. Build up of carbon in the egr pipe could be an issue.
I would suggest at the very least to do a throttle body cleaning and check the overall condition of the vacuum lines. B
 

·
Registered
1995 E320 Coupe
Joined
·
110 Posts
Discussion Starter · #4 ·
I know the EGR valve needs cleaning, but I haven't gotten around to it, as I can't seem to find much info on its removal and it seems to be a PITA. I'll probably bring it to the mechanic and get it done. As far as the OVP I remember my 260E would completely shut off when the relay went bad, on the other hand before it shut off it would do the same thing. I have to get those checked, and I'll post the results
Thanks guys,
Raxhi
 
1 - 4 of 4 Posts
Top