Mercedes-Benz Forum banner

1 - 16 of 16 Posts

·
Registered
1990 500sl
Joined
·
14 Posts
Discussion Starter #1
I own, love, and drive daily a 90 500sl with 150k miles. I try to do whatever maintenance and repairs I can and would appreciate your thoughts on ease of whatever repairs you suggest.

I currently have three concerns with my "automotive soulmate." I'll list them separately for ease of response.

My second concern is a rough idle before the car is completely warmed up. Warming up seems to mitigate, although not eliminate, the issue somewhat. It almost seems as though the engine is a little fuel-starved. I did a major tune up about 50k miles ago. Motor and tranny mounts were replaced this summer.

Thanks for your thoughts.
 

·
Greek God of the R129
SL500-500SEL-190E
Joined
·
8,371 Posts
50K is a very loooooong time.

Start with the rotors, caps, plugs, use only Bosch F8DC4.
Check the rotor brackets they have been upgraded, I and others have given the # to CK,

Regards,
aam.,
 

·
Registered
1990 500sl
Joined
·
14 Posts
Discussion Starter #3
Thanks, aam! I will take on the plugs, rotors, and caps as well as the brackets and see if this helps.

I thought these cars should be good for at least 50k on a tune up; what interval do you recommend?
 

·
Greek God of the R129
SL500-500SEL-190E
Joined
·
8,371 Posts
I do it yearly or 12K.
Remember that the block is aluminum and the plug iron = electrolysis.
Plugs are cheap &1.80 The block is not.

I replace the oil sometimes within 700 miles, or 6 months.
Why, read my thread.
Engine ticking.

If my plugs are OK I put them back, the same goes for the rest.
But you must remove & CK.
I don't mined it as it is my love... and labor. ;)

Regards,
aam.
 

·
Registered
1992 500sl R129
Joined
·
16 Posts
Try cleaning the idle control valve, might be a bit sticky ?
Also check the vacuum pipes are intact and not leaking.

Mine was showing similair symptoms, removed and cleaned the idle valve, then had to replace the rubber pipe as it disintegrated on me, all good now :)
 

·
Registered
96 SL600, 07 BMW M5 ,04 545i sold, 2013 C300 Sport (for wifey) 03 CL55 s/Chg sold,91 500SL, sold
Joined
·
112 Posts
Hello,I had a similar issue on my Mercedes R129 .My 1991 500SL used to hunt on idle between 550 to 900 rpm after initial warm-up which was about few minutes.I adjusted the fuel mixture bit rich because with age some of these cars get comfortable or should I say prefer to run abit rich or lean than original spec? Little tweaking helps.Also my car sometime surged forward at traffic lights or at stops while my foot was on the brake? I traced the remedy to my idle speed.I had to raise the idle a bit to about 750-800 rpm in park or neutral mode.This helped resolve my surging issue and idle hunt was greatly improved.Hope this helps :)
 

·
Registered
96 SL600, 07 BMW M5 ,04 545i sold, 2013 C300 Sport (for wifey) 03 CL55 s/Chg sold,91 500SL, sold
Joined
·
112 Posts
Hi Poundy,There are two trial methods that I used.The first is simple.Try adjusting the throttle cable which is next to the firewall driver side.It has a little black knob which you can turn toward you.Meaning counterclockwise.Just a few turns and you will notice a rise in your idle speed.This will also make your throttle/pedal more responsive.If this helps your idle you can leave it at that.A more advanced method will be to adjust the linkage next to the throttle body.There is an 8mm nut that can be adjusted.But you really need know what you are doing before adjusting that linkage.It's very sensitive.Most people just do the first method and leave it at that.
 

·
Administrator
1998 Pano SL500; 1993 SL500; 2005 ML270cdi
Joined
·
8,729 Posts
Also check the plastic tube that runs from the MOT module (front RH side of engine bay) and joins under the airbox. If this is damaged, or has come off, the idle will be very rough, causing hunting and surging.

On my '93 SL500 it got damaged, worn through, by the steering pump pulley.
 

·
Registered
1992 sl500 129.066
Joined
·
1,034 Posts
I own, love, and drive daily a 90 500sl with 150k miles. I try to do whatever maintenance and repairs I can and would appreciate your thoughts on ease of whatever repairs you suggest.

I currently have three concerns with my "automotive soulmate." I'll list them separately for ease of response.

My second concern is a rough idle before the car is completely warmed up. Warming up seems to mitigate, although not eliminate, the issue somewhat. It almost seems as though the engine is a little fuel-starved. I did a major tune up about 50k miles ago. Motor and tranny mounts were replaced this summer.

Thanks for your thoughts.
Have you replaced the O2 sensor or timing chain?
 

·
Registered
Joined
·
3 Posts
1992 500sl
A rough idle and hesitation. Plugs (non resistor only!) helped as did new injectors, caps, rotors and wires.
Each helped a bit but the problem was still there.
Now solved. Live in AZ and we get crappy, 91 octane CA gas. It is worse in the winter as they reformulate.
Using an octane booster (must contain MMT, not some cheepo booster)
Lucas solves the problem. Purrs like a kitten.
Has been so frustrating, thought it was my car and it was the fuel. Before doing anything add a bottle of MMT booster. Will save you many sleepless nights!
 

·
Registered
1999 SL500 (5.5 AMG)
Joined
·
207 Posts
Does the car idle rough in both stationary Nuetral and Drive respectively?
Cause my car trembles in Nuetral only.

In Drive, it idles fine.
 

·
Registered
1999 SL500 (5.5 AMG)
Joined
·
207 Posts
Check your engine and transmission mounts and harmonic balancer.
I'm not sure if you are replying to my post, but I'd think your advice would be valuable in any one of our cases.
What's a harmonic balancer? Excuse my ignorance please.

I have already replaced the engine and transmission mounts.
 

·
Outstanding Contributor
R129 500 SL 1991
Joined
·
918 Posts
I'm not sure if you are replying to my post, but I'd think your advice would be valuable in any one of our cases.
What's a harmonic balancer? Excuse my ignorance please.

I have already replaced the engine and transmission mounts.
Yes, I was replying to you. Check out the link below: -

 
1 - 16 of 16 Posts
Top