Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
94 SL 320
Joined
·
2 Posts
Discussion Starter #1
HELP!

I put the top up on my 94 SL320 last night and the roll bar indicator light went on. The top is up and the roll bar is locked down so I'm unable to put the top down..Just in time for summer too. :(

I verified the fuse was ok and even replaced it as a safe measure. Someone mentioned to me about resetting the relay panel, but I don't know how to do it.

Am I looking at a service/technician issue here?

Any input here would be appreciated.

Thanks
 

·
Registered
Joined
·
4 Posts
roll bar and rag top troubles.....

[:0] I had the same thing happen and it turned out to be a(costly service issue, as if there was any other kind than costly)!...fluid wasn't flowing correctly.....grrrrr. Good luck on this, I know what a pain it is to have the top on the fritz in Summer!!!
 

·
Registered
S500 W220 - A190 W168 - SL320 R129 (SOLD)
Joined
·
23 Posts
I have just had this problem this weekend and has been fixed today.

My light for the ro...


I have just had this problem this weekend and has been fixed today.

My light for the roof and roll bar stayed on and both did not work. I had to manually raise the roof, leaving a gap at the rear.

I took it to the MB garage today and they plugged in their computer system to the ECI brain and it showed low battery and switches at different stages, i.e. not all off or all on. He reset the memory in the car to show no errors and put the switches for rood etc to all off and then bingo!!!!!

I am to have a new battery next week.

Hope this helps...

I thought it was going to be the £1000 control box thingy...

Thanks

Kevin
 

·
Registered
94 SL 320
Joined
·
2 Posts
Discussion Starter #4
Turns out my problem was similar. I took it down manually, then had my MB technician clear...

Turns out my problem was similar. I took it down manually, then had my MB technician clear codes on the computer and at that point we just had to go through the sequence and manually reset the switches to determine where the failure occurred. Once we went through the cycle twice, it reset itself. Only cost me $60 :) so you can imagine my relief.

I already had to replace the control unit on the rollbar for US$1500 just over 1 year ago, so I knew that couldn't have been the case.

Thanks for your feedback,
Adam
 

·
Registered
S500 W220 - A190 W168 - SL320 R129 (SOLD)
Joined
·
23 Posts
Excellent news, I am still breathing a sigh of relief.....

Kevin
...


Excellent news, I am still breathing a sigh of relief.....

Kevin
 
1 - 5 of 5 Posts
Top