Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
Had to disconnect battery on 97 500SL (stored winters) and recharge. Following reconnection, startup and 20-30 minutes idling I finally found in owners manual where I had to resynchronize transmitter, power windows, ADS, etc. All this time rollbar and power top indicator and switches on and troubleshooting rollbar and top indicates performing power windows resynch first. Didn't work - any suggestions?
 

·
Registered
Joined
·
0 Posts
Discussion Starter #2
i have the same problem. my 1997 320sl was stored over the winter. the battery would not hold a charge. when a new battery was installed the rollbar swith is lit and the top switch is lit. i can't find a reason for the problem and of course the hard top is on and the top switch will not activate.<br>
<br>
help--any one?
 

·
Registered
Sl 500
Joined
·
1 Posts
roll bar / battery charge problem--500Sl

Check your fuses in the main fuse block under the hood, far left by the brake fluid resorvior. Often, these open-air fuse links develop fine hairline cracks that can deactivate rollbar and power top functions on 90-99 Sl 500s.
 

·
Registered
1998 ML320
Joined
·
12 Posts
Re: roll bar / battery charge problem--500Sl

Check your fuses in the main fuse block under the hood, far left by the brake fluid resorvior. Often, these open-air fuse links develop fine hairline cracks that can deactivate rollbar and power top functions on 90-99 Sl 500s.
I am having the same problem with my '96 500 SL after a battery failure. Fuses are OK. Talked to the dealer (120 miles away) and was told they could reset it, but had no suggestions on how I might do it. Any other suggestions?
 
1 - 4 of 4 Posts
Top