Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2000 vito 108cdi , 2000 ml 270 cdi
Joined
·
85 Posts
Discussion Starter #1
Hi my dad has got a 2005 smart roadster but it seems to be over boosting and then going into limp mode we have took the turbo off and cleaned it and checked all the pipes on the waste gate are correct , please can anyone point us in a direction so we can get it fixed thanks callum
 

·
Registered
SL500, GLC300
Joined
·
1,689 Posts
there is a smart car roadster?!?! cool! :thumbsup:
 

·
Registered
2004 S500. 2000 CLK430 Cab, 1999 C43 AMG. 1999 S500. 1999 S320. 1977 230 4 spd, 1972 280SEL 4.5
Joined
·
186 Posts
check the waste gate actuator diaphragm, the lines going to it and the electrical valve.
 

·
Registered
2005 smart Roadster, 2002 SLK 200K
Joined
·
2 Posts
I also have a smart Roadster and mine is chip-tuned to ~110 hp.
Boost is higher after tuning: 1.5 bar.
Standard is 1.0 bar I think....
How high does your boost go?
If it's higher than 1.5 bar, then there's something wrong with the waste gate.
You have to lube the actuator arm on a regular base.....try if you can still move it.
 

·
Registered
1993 Mercedes 500SL (r129) , 2001 Mercedes E240 (S210)
Joined
·
17 Posts
If it lights the engine management light and loses all power and it can be reset by pulling fuse 27 for 5 minutes or clearing the ECU errors then its most likely the cycle valve (Boost control valve). Thats the one thats in a metal case (as opposed to the one in a plastic case).
Swap it out and it should be fine. The Roadsters are susceptible to boost control valve failure and will regularly need a new one. A friend of mine carries a spare in the car and has modified its location to be easy to change he's had so many fail
 
1 - 5 of 5 Posts
Top