Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
1996 S600 (Sebastian), 1999 SLK230 Kompressor (Tie Fighter)
Joined
·
638 Posts
Discussion Starter #1
I realize there is a ton of conversation regarding the ads system, quality of ride, etc. on this forum. i'm going to take a chance and add my problem. my ride is just fine and the car rides level. however, when i press the ads switch i cannot notice any difference in the ride. none. so my questions is...is there something i should look into that maybe a non-mechanic type like me could fix or should i take it to my talented indy and let him have at it? it is not an emergency kind of thing because my ride is great. it's just me, when things don't seem to work properly then it bugs me. [8D]
 

·
Registered
1995 S600 (sold)
Joined
·
1,127 Posts
Have you been following this thread?

http://www.benzworld.org/forums/forums/thread-view.asp?tid=1201607&start=1&fid=13

Try this. With car running, and ride set to Comfort, push down on the corners of your car. Then set ride to firm, and repeat. According to MB literature, you should feel a noticeable difference. I don't on my car. I plan on digging deeper into this once I take care of some household chores I've been neglecting.
 

·
Premium Member
1997 S600 (sold)
Joined
·
4,660 Posts
Have you driven the same stretch of not smooth highway over and over again

with the system in comfort and firm mode? I can notice the difference most by driving the same freeway stretch in the two modes. The jolt that you actually feel is noticeably increased in firm mode when hitting expansion joints in the road. Or I use my wife gauge. I can see her head bobbing up and down more when driving at highway speed in firm mode. [:)]

Brett
 

·
Registered
SEC 600 V12 2dr COUPE (RHD) One of the chosen few.
Joined
·
2,233 Posts
I just had a check on the Height corrector valve.. I found that mine was seized.. a few waggles by hand with the engine running seem to have improved the ride.. I intend to repeat it next time I am underneath.. Take care with the Exhaust.. It gets hot and is in the way if you want to try what I did...
 

·
Registered
1996 S600 (Sebastian), 1999 SLK230 Kompressor (Tie Fighter)
Joined
·
638 Posts
Discussion Starter #5
ok...i tried the switch on very rough roads and DID notice a difference! however, the difference is so slight that i now know why i missed it before. i can see what they were trying to accomplish with the smoother ride and all, but i think they could have made the sport option quite a bit stiffer, the difference just doesn't seem to be enough to warrant all of the engineering, time and $$$ they put into it. also, does anyone know what exactly happens when you depress this switch? THANKS GUYS! [8D]
 

·
Registered
SEC 600 V12 2dr COUPE (RHD) One of the chosen few.
Joined
·
2,233 Posts
yes some of us know but to tell you here would take days..all the info is on this board somewhere

SO have you done all the checks?? bled the system ? done the bump test.. done the weight test??



let us know .. more information please..
 

·
Registered
1996 S600 (Sebastian), 1999 SLK230 Kompressor (Tie Fighter)
Joined
·
638 Posts
Discussion Starter #7
i'll check into the forum to try to find how it works...just interested to know how they did it.

regarding the bleed test etc....as i stated, my ride is excellent and i just wondered why i didn't feel a difference, it wasn't as though i was having problems with my ride or anything. so i tried the bumpy road test and found a very slight difference if i really paid attention for it but nothing worth mentioning, which is why i questioned the need for the system in the first place. sorry i don't have any more info for you guys but mine seems to be working as intended.
 

·
Registered
SEC 600 V12 2dr COUPE (RHD) One of the chosen few.
Joined
·
2,233 Posts
Your Sebastian's ADS system might be a little slow to respond some of them are if they are not used often.. try lifting the back from the diff housing,so tyres just touching floor(do this on flat surface)whilst running engine and switch ADS on and off a few times.. then drop and lift a few times.5 front each side 5 back switching between hard and soft. check the colour of the oil.. and the magnet in the reservoir .. see if you have muck.. will flush system round a bit give it somthing to do..last time should remain HIGH for some time and settle slowly..
 

·
Registered
500S 1996
Joined
·
30 Posts
Thank you pcmaher for the picture....I do not have ADS

So I guess my problem.....(I changed the hydraulic fluid and the back side my car is bouncing like hell now (500s 1996). It had a nice ride before.
I guess like some one mentioned above I have to wait for about 200 miles for the car to adjust itself???
The damm michanic did not mention anything about this problem arising after changing the fluid.)............

will not or better say could not be resolved by Merc600sec following suggestion.......

"Your ADS system might be a little slow to respond some of them are if they are not used often or they have switched themselves off to protect things... when you have filled with clean oil try lifting the back from the diff housing with a trolley jack,so tyres just touching floor(do this on flat surface)whilst running engine and switch ADS on and off a few times.. then drop and lift a few times.5times front each side 5times back switching between hard5 and soft5. check the colour of the oil.. and the magnet in the reservoir .. see if you have muck.. will flush system round a bit give it somthing to do..last time should remain HIGH for some time and settle slowly..then you can do the trunk test.. get two of your larger friends to climb into the back and watch to see if the self levellig system takes you back to level again..should be less than 30 seconds and then if the ride seems a bit harsh to start with.. It might just be it needs to re-learn what to do.. If you have no lights on then I would give it a couple of hundred miles to sort itself out.. then see if you need spheres etc.."

Is the only thing I can do is wait for 200 miles?
I think everything is ok down there, the ride was great
until I changed the oil, [:(]
 
1 - 11 of 11 Posts
Top