Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1 (Edited by Moderator)
I have successfully installed an aftermarket camera to my W164 ML facelift 2009 with the NTG2.5 Comand unit.

I have found lots of information on this site and also from Mhhauto.com which is an excellent software website.

I have included screenshots to help anyone do the same as me.

I did find lots of conflicting imformation, with the NTG2.5 (with the SD card slot) certainly in the UK you need developer mode, no menus available without star, the engineer mode won't help you.

Firstly you will need Mercedes star with developer mode. Fitting the camera is very easy, the hardest part is threading the wires into the tailgate through the rubber harness tube from the roof. You will need a relay to trigger the camera, you can't directly wire it to the reversing wire, the CAN system will make your camera switch off, i tried, first it gets interference then it powers off, easily cured with a cheap relay.

Once you have the developer mode you can get into the coding and change it 'fitted' but a word of warning, when i kindly got the key gen off of mhhauto.com to enable developer mode it enabled all the ecu's but just to be awkward the NTG2.5 developer mode was missing. On this site someone said you need a patch so i downloaded the patch and then tried it again, this time developer mode appeared.

I have taken pictures of each stage, i'm just trying to give a bit back to this site as its really excellent and so is mhhauto.com.

***Important - when you've changed the Comand setting you must reboot it, restart the optical ring, don't mess about with star, just hold the on button until it switches off then turn back on***

Hope this helps someone.

Do post if you have queries.

Chris
 

Attachments

·
W221 & Audio Moderator
Joined
·
10,844 Posts
Thank you, Chris - I am going to "stick" this for a time, anticipating it will be useful to others.
 

·
Registered
Joined
·
17 Posts
Greetings Skylaw,

I have read various post on this issue BUT can sort out the solution for my particular situation. I think I'm close...

My issue involves installing both a bluetooth interface (done) and confiquring a wireless backup camera for a 2006 CLS500 (the challenge).
In order to have video input at the Comand unit, I swapped the original command unit with an older version (SV-HU: 15/2003) with Frakra video input (U.S. Version). (Wanted to avoid all the video interface hardware)

Do I need STAR to activate the video signal in? Do I need to upgrade the software? Which version? Source?

Thanks for any assistance. I know this is doable.
 

·
W221 & Audio Moderator
Joined
·
10,844 Posts
I am sorry, I do not have the answers to those questions. This would best be asked on the open forum rather than is a "Sticky."

Also, I am not familiar with the head unit you are trying to install; if it is from Model Year 2003, as the info might suggest, it would be for a D2B system that is not compatible with the MOST fiber optics bus your car has.
 

·
Registered
Joined
·
27 Posts
Hi,
Can you point to the developer mode patch you used for the NTG2.5 developer menu?
When I go into NTG2.5 it only says values an be read not changed.
 

·
Registered
Joined
·
104 Posts
Discussion Starter #7
That’s quite a while ago, someone on mhh helped me with a link which was a patch. I can have a look tomorrow for you but search ntg2.5 patch see what appears
 
1 - 7 of 7 Posts
About this Discussion
6 Replies
4 Participants
Chris Souch
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top