Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
2016 E400 4Matic Sedan
Joined
·
610 Posts
Discussion Starter #1
car willn't start and no power to FP. Opened up the FPR relay and saw a large cracked joint. Had someone soldered it back and the car ran well. It ran well for a day and the same no "buzz" at KOEO happened again. Under a magnification len, I saw another cracked connection.

Question, how many of those joints do one need to resloder? All of them? Most of them look o.k.

Also, at KOEO, if I put a DMM on #7 and #8, I should get about 11 Amp, right?

Lastly, have any one purchased the KAE FPR on ebay for $92.50 delivered?

Many thanks.
 

·
Registered
Depends on the day!
Joined
·
13,337 Posts
You couldn't Pay me to put KAE parts in my car..they're chinese crap.

I have put re-built FPR's in my cars w/ good results though.

If I can help, drop a line..sorry don't know the reading's b/w pin 7 & *..never measured the bugger :-/

Jonathan
 

·
Registered
2016 E400 4Matic Sedan
Joined
·
610 Posts
Discussion Starter #3
hello Jonathan. You have been a good guy on this forum but I must tell you that your comment about "Chinese crap" strongly offended me.

Are you telling me that you don't have any product MIC in your home?
 

·
Registered
Depends on the day!
Joined
·
13,337 Posts
Sorry you took offense to the statement, but if you dealt in the world of MB parts you would know it to be a valid one. The Mercedes parts that are coming out of china right now are of such low quality that I (and everyone else in the business w/ a conscience) consider them to be crap. Now the Chinese parts aren't as bad as the Brazilian parts, but they are still something I would never install on my car or a customers car.

Jonathan
 
1 - 4 of 4 Posts
Top