Mercedes-Benz Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Ok, this has turned crazy. I have followed every instruction from older posts and NOTHING works. I have the car sold and I desperately need to reset the service b indicator. I have followed the steps, but NEVER see the "Service A/B"menu after start up. I get the voltage to appear then start up. I scroll through the menu and get the vin number, a bunch of stats with the oil level and the DSP on/off for the dyno, but nothing else????? I have read other posts and somebody else got stuck in the same spot. No "Service A/B" option to choose from. Has anyone figured this out for the 05 CLK 55????:eek:
 

·
Registered
2004 clk55 amg
Joined
·
270 Posts
turn your key to the "on" position...set the screen on your dash to the "Service A" or "Service B" screen, press and hold the reset button, the screen will beep and then ask you to hold down the reset button again for 3 seconds...do this and it'll reset the service indicator for your car...i just did this yesterday.
 

·
Premium Member
2004 CLK 240 Coupe
Joined
·
11,385 Posts
vm - I'm not sure what your reference to 'start up' means here?

blk is correct with his reply - that is the alternate way to get to the right display, by switching to posn 2 on the ignition switch. (0, 1, 2, START)

However, the method you are trying should work. After the 3 resets + beep takes you to the Voltage display, and you then turn the key to posn 2, you must first use the Menu forwards/back button to get to the Standard display (temp & miles) and then use the Scroll menu buttons (+/-) to reach the ASSYST display. :thumbsup:
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Ok, so when the car is in position 2 the car is not running? I had one turn then got the voltage and the next turn on the key I thought was ignition. So there is a position between 1 and the car running? I will try agin this evening when my wife brings the car back home. Could someone clarify that in position 2 the car is not running, thanks. I don't need to lose anymore hair!!!
 

·
Premium Member
2004 CLK 240 Coupe
Joined
·
11,385 Posts
Ok, so when the car is in position 2 the car is not running?
lol... It can be... but not unless you have already started the car. When you go to the START posn (3) you allow it to spring back to position 2 when it fires up.

So to do the reset procedure, you get to posn 2 but do not start the car! I hope that is clear.

ps. You do realize that the key goes in at position 0.
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550 FORMER: C300, ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
24,974 Posts
It's the odometer reset button - on the lower left corner of the cluster
 

·
Registered
2007 CLK350 COUPE VIN: WDBTJ56HO7F220572
Joined
·
46 Posts
i GOT A 2007 CLK350 (W209) AND CHANGED OIL ACCORDING TO THE SERVICE WARNING FOR "A"
Put the key in pos 1, pressed the squares until I saw miles since fill-up and other stuff. The total running mileage is always displayed at the bottom.
Hit the illumination/reset button 3 times=no battery voltage, no sound.
Tried it many times and can't get to Service Menu
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550 FORMER: C300, ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
24,974 Posts
You need the MFD to be displaying the speedometer, not the trip computer, when you triple-tap the reset stalk.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top