Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
2008 C300 Silver/Grey
Joined
·
10 Posts
Discussion Starter #1
So, in an ambitious effort - and after getting a ridiculous quote from my mechanic on replacing the scroll wheel (or "Push Button" as it's technically called) - I decided to buy the part and install it myself. I'm out of warranty anyway, so I figured I might as well give it a try.

To be clear, we're talking about the part that allows you to navigate through the car's computer basically (zoom in/out on navigation, scroll through lists of music, etc.). About 4 months ago, conveniently just out of my 4 year warranty, the scrolling function on the piece just plain stopped working. The up/down/left/right and push+select features work as well as the Back and Clr buttons. Just the scrolling part is non-responsive.

Anyway, I found a pretty solid guide on "opening up" the console which was pretty simple, and I was able to easily just unplug my old Push Button and replace it with a new one I purchased through an OEM dealer. Perfect solution that saved me time and money, right?

WRONG! The new replacement part literally had the same functionality as my old "broken" one (no scrolling functionality, but up/down/left/right and push+select and the "back" and "clr" buttons work).

Fortunately, I look at it as a lesson learned at not too high a cost because A) I bought the part for $130 (vs the $500 quote I was given) and B) the mechanics I normally use originally had said they would just replace that part if I had them do it (so would've ultimately been a waste of time: the same result just at the expense of me leaving my car somewhere and potentially ~$400 more dollars later).

I'm not totally braindead when it comes to DIY stuff, but now I'm pretty stumped. I've matched the part# exactly (and trust me, there are about 4 or 5 different part #'s for the Push Button on a C-Class depending on what features your car has), and still no results. My intuition says that must mean there's a short in a wire going from the car's ECU to the Push Button plug instead of problem with the Push Button itself... I'm praying though there's some small step I'm overlooking...

Any knowledgeable advice from my fellow MB enthusiasts?
 

·
Registered
2008 C300 Silver/Grey
Joined
·
10 Posts
Discussion Starter #2
I'm sorry I didn't mean ECU... I meant just the car's central computer... don't why I said ECU...
 
1 - 2 of 2 Posts
Top