Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My OEM drivers side ballast has gone out on my 98 E320 Wagon. Any idea on where to find one? I purchased a hella gen3 from ebay but the connections are different. Any idea how to modify this one or where to buy another one that works. Thanks
 

·
Registered
Joined
·
26 Posts
Aftermarket HID Lights - WARNING

Hello -

I have a 2006 Mercedes CLS 500. I had aftermarket HID lights installed in my car about 3 months ago. Since that time, I have been through 3 ballasts for the driver's side light.

During my most recent trip to the auto accessories store that installed the lights, the lead installer spoke with a former Mercedes technician about the light ballast problem. The Mercedes technician said that there are several setting changes in the Mercedes systems management computer that must be made for HID lights to work properly. Usually, these settings are updated by the factory or dealership when the original Mercedes HIDs are installed.

From what I understand, the HID-specific settings change the power requirements for the lights. Most auto accessories stores may not know about these settings or have a way to update the HID-specific settings on the Mercedes on-board computer. It now appears that having inappropriate settings in the systems management computer result in the incorrect amount of power being sent the HID light ballasts, causing them to burn out. Fortunately, I know a former Mercedes technician who will update the HID-specific settings in my systems management computer. I will let everyone know if those changes fix the ballast problem.

Just remember to ask your installer if he can make the appropriate changes on the Mercedes system management computer before you buy aftermarket HID lights. I am not sure if a Mercedes dealer will make the setting changes for you if you do not purchase the Mercedes HID lights, but it does not cost anything to ask.
 
1 - 2 of 2 Posts
Top