Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
94 s420 98 s420
Joined
·
539 Posts
Discussion Starter #1
Hello all! I recently replaced my right front and rear door ( 1994 s420)due to a swide swipe. My front door had power and everything worked fine, however my rear door had no power what so ever. No locking assist no power locks, no light, no cigarrette lighter. I even went as far as replacing the new doors harness with my old one and i still had no power to anything. I highly doubt its any of the pumps since the rest of the doors function properly. ALso its more then one function that does not work.I also noticed that my fuel lock no longer operates as well. Everything worked well before i switched the doors. Any help as to where i can look and to why i get no power only to the rear right door is greatly appreciated.
 

·
Registered
94 s420 98 s420
Joined
·
539 Posts
Discussion Starter #2
I noticed today that everytime i lock or unlock the door the vaccum pump under the seat turns on. is this normal? should the vaccum pump run everytime you lock or unlock the doors? or should it be several cycles of locking and unlocking before the pump turns on. is there a reservoir that holds vaccum. I dont think i heard this pump this much till I changed the doors, any feedback would be great. I still have no power what so ever to my reaar right door. I will check the door plug again to ensure that the body shop has it plugged in right. if anyone can think of osmething else please reply.
 

·
Registered
92 500SEL to 01 E320T current 2014 lexus LS460
Joined
·
3,886 Posts
On the 140 body, the pump provides either pressure or vacuum to lock and unlock. it provides a constant pressure for the lumbar support, and it provides back up vacuum for the heating and A/C system to activate the diaphrams when there is no vacuum availble (during acceleration or rest). Did you check, or is the door pillar connector possibly damaged. I dont have a manual handy but that connector has both vacuum and electrical, and as I recal has a turn latch to seat and hold. The front conector has a slide latch and the rear supposedly has a special squre tool 6mm square to release.If your fuel door does not work I suspect a leak or bad pump since they are in parallell. There is a distributor plate on the pump.
 

·
Registered
94 s420 98 s420
Joined
·
539 Posts
Discussion Starter #4
Thank you for your input pete, i would hate to think its the pump since everything was fine before i swiped out the doors, also there is no power what so ever like i said before cigarette lighter, light, door locks and door assist. Initially the new door (from a junk yard) was from a s 600 which had the recliner switches that my s420 doesnt have. I thought that was the problem at first, so i took out that hole door harness and replaced with mine from the old door. still i get no power to that door. not even the window. it sounds as its a plug issue or something that would control all those options together.
 

·
Registered
92 500SEL to 01 E320T current 2014 lexus LS460
Joined
·
3,886 Posts
Check that plug in the door pillar! all the electrics, speakers, and vacuums come thru that. The 600 had closing assist, I dont know how that affects it.
 

·
Registered
94 s420 98 s420
Joined
·
539 Posts
Discussion Starter #6
yes its more then likely the plug pete thats where iam aiming to, I havent had the chance to try since its very difficult without a shop. What i meant about the 600 was, the recliners, the 600 had a rear recliner switches on the door and the harness was slightly different then mine, at first i thought it was the harness, so i had the body shop swipe out harnesses with my old one. I really think is the plug since i get no power to anything. I will write back and tell you how it goes once i fix this problem.
 
1 - 6 of 6 Posts
Top