Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
2004 C230 Coupe, 2002 c240 Sold, 2002 C230 Sold, 2001 Yellow SLK (Sold :( )
Joined
·
32 Posts
Discussion Starter #1
Had the "alternator/battery" warning on my W203, checked battery OK (manufactured 2011), replaced alternator with Bosch remanufactured, checked the battery voltage while driving and idle perfect (13.8, 14.4V).

2 days ago, alternator stopped charging, took it off, bench tested advance auto parts, no problem---go figure

Put it back on the car, checked voltage, alternator charging. Today, no more charging. This is becoming a puzzle....

Anyone had same problem?

BTW, what is that plug on the alternator? what does it do? can be the culprit? Cable tight on alternator

Any ideas are greatly appreciated!
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
19,441 Posts
Plug? There should only be two wiring connectors - positive and negative. Maybe there is a test connector? Anyhow, this could be a defective voltage regulator. Did you replace it with the alternator (it bolts onto the back). Or, it could be a defective wiring harness.
 

·
Registered
2004 C230 Coupe, 2002 c240 Sold, 2002 C230 Sold, 2001 Yellow SLK (Sold :( )
Joined
·
32 Posts
Discussion Starter #3
Thanks for your reply!!!

I bought a remanufactured bosch alternator from advance auto parts (shouldnt come with a refurbished voltage regulator?). I took the alternator plug and tested the voltage (from what I have read, the plug powers/energizes the alternator so it can generate) and I found 12 V on it, so looks like it is getting voltage from the car.

I am now tempted to take it apart again, unistall the alternator and replace the voltage regulator myself, is this hard to do? or just plug and play few screws?
 

·
Registered
2004 C230 Coupe, 2002 c240 Sold, 2002 C230 Sold, 2001 Yellow SLK (Sold :( )
Joined
·
32 Posts
Discussion Starter #6
I just cleaned the terminals (baking soda and brush). removed the terminals soaked in a cup with baking soda, then brushed, then brushed battery terminal.

Turned ON the car, the volts is 12.3 at idle :(

Looks I am going to have to trickle charge the battery all night and carry my boat's spare battery just in case for tomorrow going back to work.:confused:
 

·
Registered
2004 C230 Coupe, 2002 c240 Sold, 2002 C230 Sold, 2001 Yellow SLK (Sold :( )
Joined
·
32 Posts
Discussion Starter #7
Also, to add, when the alternator works the interior lights flicker
 

·
Registered
2005 C240 silver, 2008 R320CDI Cubanite
Joined
·
390 Posts
The regulator/alternator works as one. the regulator controls the rotor current so that the stator winding, which provides all the current, is at the correct voltage. It should be good if it is new.

Try to check the ground connection from the alternator to the chassis/battery.
 
1 - 8 of 8 Posts
Top