Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
W202 C180 1995
Joined
·
17 Posts
Discussion Starter #1
Well addes to my rattle another problem surfaced today. The passenger seat. This is a powered unit and has full functionality apart from moving forward or backwards.

I have checked fuses in the boot. All Ok. I removed and refitted the relay, also in the boot and the issue remains. I then swapped over the drivers side control switch and that didnt change anything.

The seat is in such a position that i can easily access the rear 2 bolts but the fronts i cant. How can i move the seat back to access the front bolts?
 

·
Registered
1995 C220
Joined
·
2,756 Posts
try tapping on the motors with a mallet and see if it will move. Sometimes the motors get a dead spot in them and get stuck.
 

·
Registered
2002 Mercedes ML320, Mercedes 190E 2.3L (sold), 2001 Mercedes c320(gone)
Joined
·
1,391 Posts
I'm imagining you can trace the wires for the motor, take out the fuse, unplug the connectors, isolating the motors from the car... and hot wire the motor... Possible?

Sent from my Pace 2 Lite using Tapatalk
 

·
Registered
W202 C180 1995
Joined
·
17 Posts
Discussion Starter #4
Service resumed. Why? I don't know. It just started working again
 

·
Registered
1999 C280, 2000 C280, 2000 C230K,2011 C300
Joined
·
639 Posts
When it is intermittent, then most likely the seat relay in the trunk. When you inspect, you'll see the cracked solder joints on the small board. You can easily repair if you are handy with small soldering iron, or maybe $40 for a new one from MBZ.

 
1 - 5 of 5 Posts
Top