Mercedes-Benz Forum banner

Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
1991 190E 2.6
Joined
·
11 Posts
Discussion Starter #1
Hello everyone can someone out there tell me how to remove the instrument cluster out from a 1991 190e 2.6. I was told that you just pull it out with dash puller tool. Is this true.
 

·
Registered
92 190e 2.6 Sportline
Joined
·
55 Posts
the first thing you need to do is go to the rear of the transmission and disconnect the spedo cable from the trans. this will give you more room to pull the cluster out. then take out the center vents so it will give you something to grab onto. its just a compression fit cluster, just wiggle it back and forth to get it to come out. then you can reach your hand around and start disconnecting wires. start from the left and go to the right.
 

·
Registered
1991 190E 2.6
Joined
·
11 Posts
Discussion Starter #5
U know turnpike that is why fourme is there for. If you don't know you can ask questions person like you shouldn't reply to any question any one asks because you reply like this. You just make me mad.
 

·
Registered
'87--190E 2.3-16v(being rebuilt), '99--C230 Kompressor
Joined
·
3,488 Posts
and noobs that come to the forums w/o following proper forum etiquette are more of a annoyance to many members. you think that all the information is just going to just gush out of "tenured" members. instead of assuming that everyone is going to jump up and give you the information you want, why not try being a little more proactive and searching for the information you need...THEN if you still have issues that is the time to ask questions. at least once a month some new owner comes on here and asks the same question. thats why the search function exists to look for information....and i may point out that my 1st response was not rude, but merely stating the fact that there is more then one write up on the subject there fore i did not feel the need to re-iterate what has been said many many times over...

(note: over 480 threads with the word cluster found in .65 sec)
 

·
IR MODERATOR
1996 Volvo 855GLT, 1993 MB 190e 2.3 8v, 1998 Subaru Outback SUS, 1991 BMW 525, 1998 MB C230
Joined
·
9,228 Posts

·
Registered
92 190E 2.3 SOLD, 91 420SEL, 95 C280
Joined
·
488 Posts
I see all too often that a new member asks a question that is very pertinent to their particular situation, and instead of getting good information they are instead told to use the search, or fill in their profile. I'm afraid that has the tendency to turn people off. If the "veterans" don't want to answer a question that has been asked before they simply won't.

On another note the search feature isn't really all that user friendly. Sure you get a bunch of posts that contain the word used, but then you have to sift through and hope you found the right answer.

I would argue that many of the "noobs" are asking out of a frustration trying to correct an issue with their beloved W201 and getting anything short of a good informative answer does nothing to increase the membership and the vast knowledge that this forum has the ability to produce.
 

·
IR MODERATOR
1996 Volvo 855GLT, 1993 MB 190e 2.3 8v, 1998 Subaru Outback SUS, 1991 BMW 525, 1998 MB C230
Joined
·
9,228 Posts
Frequently Asked Questions - READ THIS FIRST!

FAQ thread it also saids read this first before posting and all the basic stuff like cluster removal is in there. im not trying to be a dick. if theres something thats not there that you think should be there let rjb or myself know and we'll add it.
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top