Mercedes-Benz Forum banner
1 - 4 of 4 Posts

·
Registered
'06 E350/4-Matic
Joined
·
16 Posts
Discussion Starter · #1 ·
Hi All!

I've got a bit of an issue; I own an '06 E350 4-Matic, purchased CPO, and still under the CPO warranty....

My rear sunshade works, but is driving me nuts with squeaks. It seriously sounds like chipmunks wrestling on the parcel shelf. My local dealer has "looked at it, and tightened it up" a few times, which in my opinion means they've done nothing. The seats haven't come out, nothing's been fixed.

Do you have any advice as to either how i can fix it/common sources for squeaks, or do you recommend another path to getting this fixed?

Any thoughts/ideas/experiences would help. I know it seems small, but every bump and every bass hit makes it squeak, and it's really unnerving to the rear seat passengers, and me!

-Andy

PS: My GF's 2004 Saturn Ion doesn't squeak as bad as this.... Sad, but true.
 

·
Registered
2013 E350 Cabrio A207
Joined
·
68 Posts
I've got the rear sunshade in mine, and it doesn't make a sound. Stay after the dealer if you're under CPO warranty!
 

·
Registered
2012 ML350 4Matic
Joined
·
297 Posts
Get a tech to ride with you and show him the problem. That's the best way to get things fixed properly under warranty.
 

·
Registered
2008 ML320CDI Iridium Silver/Black, NAV, P2 pkg, Sirius, Harmon Kardon. Active Bi-Xenon
Joined
·
478 Posts
Mine was not going up and down smoothly, it would ratchet up from left to right on occasion. Dealer replaced without issue. CPO vehicle is like new vehicle warranty. I cannot believe they are just not replacing it.
 
1 - 4 of 4 Posts
Top