Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
The 'door' setting on my rear hatch light does not work. It stays on even when you shut the rear hatch. Also, the key FOB does not lock/unlock the rear hatch only. Is there a correlation between the two? Help!
 

·
Registered
98ML320
Joined
·
1,278 Posts
when you lock and unlock the hatch, do you hear the lock motor actuating in the hatch? If you hear the motor working then it's probably the link between the door lock and motor that has come loose. THere are tons of instructions on the board to fix that.

Can't say why the light won't go off although there is a manual off switch which you might use in the meantime. It could be related and maybe someone else can chime in about that. Fix the lock first and see if that solves your light problem else you'll need to do more investigation.

Now that I think about it there must be a physical switch in the hatch frame somewhere that triggers the light. shouldn't be hard to find and test by pressing it in. If the light goes out when you press the switch then your doors not triggering the switch or if nothing happens the switch is broken. Can't be an expensive or difficult part to swap.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
When I push the back hatch button nothing happens at all. No sound or anything coming from the the door. And when I push the lock or unlock buttons everything works properly but the rear hatch.
 

·
Registered
98ML320
Joined
·
1,278 Posts
If there's no sound at all from the trunk then I'd guess there are 2 possible problems. Either the connector the the lock has gotten loose somehow and can be fixed by replugging it in (at the lock). Or the lock has broken which would mean it needs to be replaced. I haven't done this particular lock myself so I can't say it's easy or hard but I suspect it's not that hard to swap out. (versus the door lock which involves rivets and drilling)

As a long shot it may be the wiring to the trunk lock being the problem but it's doubtful.
 

·
Registered
Black 2005 ML 500
Joined
·
1,662 Posts
I guess we need some more info to understand the real problem.

1.- Does the trunck open manually using the handle..?

If it does, then the lock rod is in place and
working.

If it doesn't then your rod connectiong the handle
mechanism and the locking mechanism at the end of
the door has been diconnected and you will need to
secure it again.

2.- Does manually locking the door(from inside), works..?

Then the locking mechanism is working.

3.- If there is no sound comming from the hatch, when you lock or unlock the hatch, then your actuator may have failed (the magnetic coil mechanism). You will need to change it.

My hatch light only works manually. That is using the light switch at the ceiling close to the hatch, and it will not turn off automatically. It will only turn on if it is at the middle position. I thought this was always normal, Though, I noticed this when I last changed my actuator and the mechanism the dealer gave me did not exactly match the one I had there before for whatever reason... The original actuator had an extra wire on it that the new one I bought did not had. Didn't had time to go back to the dealer and everything worked ok, so I did not pay to much attention.

AC
 

·
Registered
1999 Kleemann ML43K
Joined
·
1,390 Posts
AC_ML - 4/24/2005 11:39 AM


My hatch light only works manually. That is using the light switch at the ceiling close to the hatch, and it will not turn off automatically. It will only turn on if it is at the middle position.
AC
I can't help you with your hatch/locking issue as I had mine replaced under waranty two years ago when it was rattling and driving me nuts.

As far as the rear hatch light:

For my '99 there are three positions for the rear hatch dome light: (1)position 1 all the way to the left has the light off at all times. (2)position 2 in the center is light ON at all times. (3)position 3 all the way to the right is light on ONLY when the hatch is open. This is where I keep mine at all times so I can see better at night when I'm unloading.

Good luck with the locking issue! Sorry I could not help...
 

·
Registered
Black 2005 ML 500
Joined
·
1,662 Posts
I guess that is the extra wire that my new lock/actuator assembly did not have. That sensor wire must be connected to a relay and will provide the feedback on when the door is open.

I guess that is why my extreme left and right switch position work the same way..

Thanks for the information.. :)

AC
 

·
Registered
Joined
·
1 Posts
Firstly, I'm a new member to the forum but have browsed it for over a year now. Fantastic posts and excellent advice. Thanks to all.

As for jchilds23's problem, I had the same exact problem (light stays on and remote rear latch won't work). I originally thought it was the door actuator as other members have posted, however after purchasing installing a new actuator, it did not fix my problem. After further investigation, I noticed that the actual latch/lock mechanism has a switch built into it that senses if the door is closed or not. I replaced the rear latch/lock part# 163-740-02-35 for $67.00 @dealer and it solved my problem.

In hindsight, my wife tried to close the rear hatch door and for some reason, the latch stayed in the closed position. This was probably the cause of the switch breakage. Hope this helps
 
1 - 8 of 8 Posts
Top