Mercedes-Benz Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have read the forums on here and other ones in regards to this and have gotten nowhere. Does anyone have detailed or illustrated instructions on how to resolve this? Also does anyone off hand know how much it would cost if I had to bring it to MB to get it fixed. The dealerships here in NJ automatically charge 150 bux just to look at your car! If anyone can help it would greatly be appreciated. Thank you!
 

·
Registered
2000 Mercedes Ml320
Joined
·
106 Posts
I have not experienced this with mercedes yet. My 1992 BMW 735iL driver seat got stuck in a 180 degree angle due to someone laying down. The dealer wanted to charge me $3200 to rebuild me a brand new seat. I went to the junk yard and bought a different color seat and put seat covers on and it was $300. Its a pain and annoying.
 

·
Registered
2000 ml320 & 2002 c32 AMG
Joined
·
61 Posts
I just had this problem last week.
Under the seat there is a wire that connects one part of the seat to the other.
Mine was loose, and after getting annoyed at it for about 10 mins, the seat decided to start working. It worked for me just to jiggle the cable and reattach it. Hopefully this helps..
 

·
Super Old Fart Moderator
2002 ML320, 2005 S430 4MATIC RIP, 2010 F150 Crew Cab
Joined
·
11,790 Posts
I just had this problem last week.
Under the seat there is a wire that connects one part of the seat to the other.
Mine was loose, and after getting annoyed at it for about 10 mins, the seat decided to start working. It worked for me just to jiggle the cable and reattach it. Hopefully this helps..
Ditto that. Sometimes the cable comes off and has to be reattached. It's a pain to do if the seat is down, though.
 

·
Registered
2005 E320 CDI, 2016 E250
Joined
·
3,199 Posts
Detatched mine this weekend by accident...Such a pain.Check the cables first.
 

·
Registered
2007 ML 500, 2008 ML 550, 2011 ML 63 AMG
Joined
·
363 Posts
Unless I'm missing something the OP is talking about the rear drivers side seat not working, i.e. the flip & fold part.

While I've not had that happen (yet) on my ML, it does it all the time on my Land Rover, it's usually caused by it not being fully latched down (or up) in the first place, if it won't go up, check that it's all the way down first.
 

·
Registered
03ML320
Joined
·
26 Posts
I had this happen to my rear middle seat belt. I let the rear seat down and the seat belt was stuck and I couldn't get the seat up. I tried to take the seat back off and loose the belt roller. Didn't work. I ended up having to cut the seat belt so I could use my rear seat.
 

·
Registered
2005 E320 CDI, 2016 E250
Joined
·
3,199 Posts
My bad...reread it...Murf is right.

OP...I know this will sound stupid...but did you read the directions on correctly raising and lowering?

A brief instruction (from memory) is:

While they are up...push the button and grip the "D" handle to pull the seat forward while griping the "L" handle at the side and pulling outward. Sit the seat on the floor...and pull the "button" on the top corner of the seat back...that will fold the back down flat.

The instructions in reverse are used to put the seat back up. If you cannot move the seat...there may be an obstruction causing that. Check what you can to make sure the braces and struts are clear under the seat. (I realize there is not much clearance).

Hope this helps.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top