Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
So on my 91 350 SDL I've been beating my head over this I'm utterly confused, my foot vents work but only open when the switch is off. Once I turn it on the vents close, what I've already fixed is the vacuum control valve (new), fixed the vacuum leaks and I have a good working control unit (its good its been swamped from my 560SEC for testing). PLEASE HELP!!!!!
 

·
Registered
1984 500 SEL euro, 1989 560 SEL, 1980 450 SL, 1981 DeLorean, 2013 F10 BMW
Joined
·
1,253 Posts
It sounds as if you may have a vacuume line crossed. Either on the vac pod or even on the 'Gang of Six' control unit. The controller has a colour code on the side to indicate the line placement. I would check whether the vac pod lines have been swapped.

Regards,
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
I triple checked the vacuum lines and they are all in the correct spot, Would any of the temp sensors affect this I'm thinking it wouldn't but I've been surprised before. Does anyone have a wiring diagram for the control unit it self?
 

·
Registered
Joined
·
1,648 Posts
default - (no vacuum) is for all air to go to the defrost vents, nowhere else - NOT the floor. Select defrost and see if ALL of the air goes to the defrost vents. Then unplug the vacuum line from the engine - again all the air should stay at defrost. If that is not working right then vents are opening when they should be closing which seems to fit your description.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
So here's a update, I finally got back to playing around with it and accidentally pushed the recirculating switch on and then the floor vents started to work, so now I'm thinking of checking the ground circuit. Anyone have a good wiring diagram for the HVAC system
 
1 - 5 of 5 Posts
Top